Einführung in Insight

Version 15

Hinweise zu dieser Version

Dies ist die erste Release von Version 15 der Einführung in Insight. Wir stellen weiterhin Aktualisierungen für dieses Dokument im Rahmen von neuen Solid Edge-Releases und auf der Webseite für Solid Edge-Kundenunterstützung zur Verfügung.


Vorwort

Zu diesem Dokument

Dieses Dokument bietet Ihnen Informationen über Installation und Verwendung von Microsoft Sharepoint Portal Server, mit dessen Hilfe Sie Ihre Solide Edge-Dokumente auf effektive Weise verwalten können.

Weitere Quellen

Derzeit sind eine Reihe von weiteren Dokumenten mit ausführlichen Informationen über Microsoft Exchange Server und SharePoint erhältlich. Es handelt sich hierbei um folgende Dokumente:

Microsoft SharePoint SDK Online-Hilfe

SharePoint-Webseite, http://www.microsoft.com/sharepoint

Microsoft-Kundenunterstützung, http://support.microsoft.com/directory

Handbuch für Windows SharePoint Services-Administratoren http://www.microsoft.com/technet/treeview/default.asp?url=/technet/prodtechnol/windowsserver2003/deploy/confeat/wssAGabs.asp.

SharePoint-Newsgroups

Insight-Newsgroup


Checkliste

Sie müssen diese Checkliste durchgehen, um sicherzustellen, dass Sie Solid Edge Insight richtig implementieren. Informationen zur Anwendung dieser Checkliste finden Sie in diesem Dokument.

  1. Windows 2003 Server ist geladen.

  2. SharePoint Portal Server 2003 oder Windows SharePoint Services 2003 ist geladen.

  3. Site wurde erstellt.

  4. Dokumentbibliothek wurde erstellt.

  5. Der Dokumentbibliothek wurden Eigenschaften hinzugefügt.

  6. Neue Ordner wurden hinzugefügt.

  7. Rollen wurden zugewiesen.

Weitere Informationen finden Sie unter Capacity Planning for Microsoft SharePoint Portal Server 2003 im Handbuch für Windows SharePoint Services Administratoren http://www.microsoft.com/technet/treeview/default.asp?url=/technet/prodtechnol/windowsserver2003/deploy/confeat/wssAGabs.asp.


Systemvoraussetzungen

Mindestkonfiguration für Insight Server

  1. System mit mindestens einem Intel Pentium III-kompatiblen Prozessor

  2. Mindestens 512 MB Arbeitsspeicher (RAM)

  3. Mindestens 550 MB freier Festplattenspeicher; Festplatte im NTFS-Dateisystem erforderlich.

  4. Betriebssystem Windows 2003 Advanced Server

  5. SharePoint Portal Server 2003 oder Windows SharePoint Services 2003 ist geladen.

  6. SQL Server 2000 SP3

Empfohlene Konfiguration für Insight Server

  1. Intel Pentium 4

  2. Dual-Prozessor empfohlen

  3. 1 GB Arbeitsspeicher (RAM) empfohlen

Mindestkonfiguration für Insight Client

  1. Intel Pentium III, Intel Pentium 4 oder AMD Athlon.

  2. 512+ MB RAM.

  3. Internet Explorer 6,0 oder höher.

Leistungsempfehlungen

Die folgenden Empfehlungen helfen Ihnen, die Leistung von Insight zu verbessern.

  1. Stellen Sie sicher, dass Sie über mindestens 300 MB Festplattenspeicher für temporäre Internetdateien verfügen. Hierzu klicken Sie im Internet Explorer im Menü Extras auf Internetoptionen. Klicken Sie im Dialogfeld Internetoptionen auf der Registerkarte Allgemein auf Einstellungen. Geben Sie im Dialogfeld Einstellungen im Feld Zu verwendender Datenträgerspeicher: 300 ein. Entfernen Sie den Ordner für temporäre Internet Explorer-Dateien von Ihrem Systemlaufwerk und platzieren Sie ihn auf einem anderen Laufwerk, falls Sie über eine Systemkonfiguration mit mehreren Festplatten verfügen.

  2. Befolgen Sie die Empfehlungen von Microsoft auf der SharePoint-Website unter http://www.microsoft.com/sharepoint, wenn Sie Protokolldateien, Indizes und Sicherheitskopien erstellen.

  3. Stellen Sie sicher, dass Sie die mit Ihrer Software gelieferte Dokumentation gründlich durchlesen und verstehen, um Geschwindigkeit und Sicherheit abzustimmen.

  4. Die empfohlene Höchstgrenze für Dokumente pro Ordner ist 10.000.

  5. Die empfohlene maximale Dokumentgröße auf dem SharePoint Portal-Server ist 230 MB.

Wir empfehlen außerdem, dass Sie an einem der verfügbaren Microsoft Windows Server 2003 Trainingskurse teilnehmen, die eine Quelle für wertvolle Informationen darstellen. Weitere Informationen finden Sie unter:

http://www.microsoft.com/traincert/centers/windowsserver2003.asp


Unterschiede zwischen SharePoint 2001 und Windows SharePoint Services 2003

Zwischen den Funktionen von Microsoft SharePoint 2001 und Windows SharePoint Services 2003 bestehen mehrere Unterschiede.. Es ist wichtig, vor dem Implementieren von Insight Server diese Änderungen zu verstehen.

Benutzerrollen

Microsoft SharePoint 2001 stellte Ihnen drei Standardbenutzerrollen zur Verfügung:

  1. Leser

  2. Autor

  3. Koordinator

Die Funktionen dieser Rollen waren bisher fixiert und konnten nicht angepasst werden. Mit Windows SharePoint Services 2003 stehen Ihnen fünf standardmäßige Benutzer-Websitegruppen zur Verfügung:

  1. Gast

  2. Leser

  3. Teilnehmer

  4. Webdesigner

  5. Administrator

Die Rollen zwischen den beiden Versionen verteilen sich etwa folgendermaßen:

Microsoft SharePoint 2001 - Rolle | Windows SharePoint Services 2003 - Websitegruppe
Leser | Leser
Autor | Teilnehmer
Koordinator | Administrator

Die Gastgruppe entspricht in etwa der Leserrolle, die jedoch von Liste zu Liste festgelegt wird. Diese Rolle kann einem Benutzer nicht auf Websiteebene zugewiesen werden.

Die Webdesignergruppe ist der Administratorgruppe sehr ähnlich, kann jedoch weder Benutzer verwalten noch neue Websites erstellen.

Windows SharePoint Services 2003 führt außerdem das Konzept von Benutzerrechten ein. Benutzerrechte sind gesonderte Berechtigungen wie Durchsuchen, Löschen und Bearbeiten, die kombiniert werden können, um Windows SharePoint Services 2003-Websitegruppen zu erstellen. Da Gruppen sich aus einzelnen Rechten zusammensetzen, können die Standard-Websitegruppen in Windows SharePoint Services 2003 geändert werden. So können Sie beispielsweise die Löschberechtigung aus der Teilnehmergruppe entfernen, um die Benutzer am Löschen von Dateien zu hindern. Sie können außerdem neue Websitegruppen erstellen.

Weitere Informationen finden Sie im Handbuch für Microsoft Windows SharePoint Services 2003 Administratoren.

Ein weiterer Unterschied zwischen Microsoft SharePoint 2001 und Windows SharePoint Services 2003 besteht in der Art und Weise wie Berechtigungen zugewiesen werden. In Microsoft SharePoint 2001 war es möglich Benutzerberechtigungen auf Ordnerebene zuzuweisen. In Windows SharePoint Services 2003 werden Berechtigungen und Gruppen auf der Stammwebsite festgelegt, die in untergeordneten Websites oder Dokumentbibliotheken überschrieben werden können.

Sie können den Windows SharePoint Services 2003-Gruppen Benutzer nur auf Dokumentbibliotheksebene zuweisen.

Falls Sie die in Microsoft SharePoint 2001 vorhandene ordnerspezifische Funktionalität nachahmen wollen, müssen Sie für jeden Satz von eindeutigen Berechtigungen eine neue Website und Dokumentbibliothek erstellen. Weitere Informationen hierzu finden Sie im Dokument Insight von Microsoft SharePoint 2001 zu Windows SharePoint Services 2003 migrieren.

Eigenschaften

Microsoft SharePoint 2001 lieferte grundlegende Eigenschaftsdatentypen, die in Profile gruppiert werden konnten. Windows SharePoint Services 2003 fügt neue Datentypen hinzu und bietet neue Optionen, die für jede Eigenschaft eingestellt werden können.

Windows SharePoint Services 2003 - Spaltentyp | Microsoft SharePoint 2001 - Eigenschaftstyp
Eine oder mehrere Textzeilen | Text
Zahl | Zahl (nur Ganzzahl)
Auswahloption | Auswahlliste mit mehreren Werten
Mehrere Textzeilen | Kommentarfeld (4096 Zeichen)
Datum/Uhrzeit | Datum
Nachschlagetabelle* (Daten werden von anderer Stelle in SharePoint abgerufen) | nicht anwendbar
Hyperlink* | nicht anwendbar
Ja/Nein | nicht anwendbar
Berechnet* (der Wert für die Spalte wird aus anderen Spaltenwerten berechnet) | nicht anwendbar
Währung* (wird als Dezimalzahl mit dem entsprechenden Währungssymbol angezeigt) | nicht anwendbar

* Dieser Eigenschaftstyp ist nur im SharePoint-Dashboard für Insight V15 sichtbar. Er ist in Solide Edge-Dateien weder sichtbar noch synchronisiert.

Windows SharePoint Services 2003 bietet neben den neuen Spaltentypen zusätzliche Formatierungsoptionen, mit denen Sie sicherstellen können, dass dem System gültige Werte hinzugefügt werden. Einige dieser Formatierungsoptionen sind:

  1. Min./max. Werte für Zahleigenschaften

  2. Anzeige als Prozentsatz

  3. Standardwerte

  4. Berechnete Werte

  5. Anzahl der Dezimalstellen

Administratoren können außerdem die Standardansicht ändern und "Systemspalten" im Dashboard ausblenden, damit die Benutzer sich auf die wichtigen Daten konzentrieren können. Insight nutzt diese Option, indem es die Anzeige aller erforderlichen Insight-Eigenschaften ausschaltet.

In Microsoft SharePoint 2001 verfügten Administratoren lediglich über begrenzte Möglichkeit zur erfolgreichen Änderung von Eigenschaften. Hierbei wurde zwar der angezeigte Name geändert, der zugrundeliegende Eigenschaftsname blieb jedoch unverändert. Dies gestaltete die Synchronisierung von Eigenschaften als äußert schwierig, sobald ein Eigenschaftsname geändert wurde. In Microsoft SharePoint 2001 waren außerdem Leerzeichen in Eigenschaftsnamen nicht gestattet. Mit Windows SharePoint Services 2003 können Administratoren jetzt Spaltennamen nach Bedarf ändern und Leerzeichen in den Spaltennamen verwenden. Beim Ändern von Spaltennamen müssen Sie überprüfen, ob andere Spalten die umbenannte Spalte als Nachschlagetabelle verwenden. Ist dies der Fall, müssen Sie die Nachschlagetabelle aktualisieren, damit diese auf die umbenannte Spalte verweist. Windows SharePoint Services 2003 schränkt die Gesamtzahl der Spalten in einer Dokumentbibliothek basierend auf deren Datentyp ein. Die Einschränkungen für jeden Spaltentyp sind:

  1. 64 (57/51) Textspalten pro Liste (einzelne Textzeile, Auswahlliste, Hyperlink, Bild)

  2. Mehrzeiliger Text – 32 (31/29) Spalten

  3. Zahl oder Währung – 32(32/31) Spalten

  4. Datum – 16 Spalten

  5. Nachschlagetabellen – 16 Spalten

  6. Ja/Nein – 16 Spalten

  7. Berechnet - 8 Spalten

Hinweis: Die in Klammern () angegebenen Werte gelten für Dokumentbibliotheken, da hier mehrere Spalten vom System verwendet werden. Der an erster Stelle aufgeführte Wert gilt für SharePoint-Dokumentbibliotheken. Der an zweiter Stelle aufgeführte Wert gilt für Insight-Dokumentbibliotheken.

In Windows SharePoint Services 2003 werden Eigenschaften auf Ebene der Dokumentbibliothek festgelegt. Dokumentprofile gibt es nicht mehr. Wenn Sie bisher in Microsoft SharePoint 2001 mehrere Profile verwendet haben, müssen Sie die Eigenschaften aus den verschiedenen Profilen in einer Dokumentbibliothek zusammenfassen oder für jede Eigenschaftsgruppe eine separate Dokumentbibliothek erstellen. Um das Replizieren gemeinsamer Eigenschaften zu vereinfachen, können Sie eine Dokumentbibliothek mit allen erforderlichen Eigenschaften erstellen und diese als Vorlage für zukünftige Dokumentbibliotheken speichern. Weitere Informationen hierzu finden Sie im Dokument Insight von Microsoft SharePoint 2001 zu Windows SharePoint Services 2003 migrieren.

Sicherungskopien und Wiederherstellung

In Microsoft SharePoint 2001 wurde beim Erstellen von Sicherungskopien der gesamte Webspeicher einbezogen, wodurch sich das Sichern umfangreicher Arbeitsbereich schwierig gestaltete. Mit Windows SharePoint Services 2003 können Sie während das System in betrieb steht einzelne Websites sichern. Bei dieser Art der Sicherung werden Sie jedoch einen Leistungsabfall bemerken. Wenn Dateien nach Websites angeordnet sind, können Sie den Leistungsabfall reduzieren, indem Sie Sicherungskopien Website für Website erstellen. Websites die sich nicht regelmäßig ändern, wie z.B. Standard Parts, können in die wöchentliche Sicherung einbezogen, jedoch bei der nächtlichen Erstellung von Sicherungskopien übergangen werden. Weitere Informationen zu diesem Thema finden Sie im Handbuch für Microsoft Windows SharePoint Services 2003 Administratoren.

Versionsgrenzen

In Microsoft SharePoint 2001 war es möglich eine Versionsgrenze (gewöhnlich 3) festzulegen. In Windows SharePoint Services 2003 kann die Versionierung eingeschaltet werden. Es besteht jedoch keine Möglichkeit mit Windows SharePoint Services 2 eine Versionsgrenze festzulegen.

Hinweis: Für Insight-Benutzer empfehlen wir wegen der extrem hohen Speicherplatzerfordernissen bei unbegrenzten Dokumentversionen die Versionierung ausgeschaltet zu lassen, bis ein Dienstprogramm zum Festlegen von Versionsgrenzen oder eine automatisierte Methode zum Entfernen von Versionen aller in einer Dokumentbibliothek enthaltenen Dokumente zur Verfügung steht.


Installation der SharePoint Server Software

Beim Installieren von Microsoft SharePoint Services müssen Sie einige Punkte beachten. Ausführliche Anweisungen über die Installation von Windows 2003 Server, SQL Server 2000, SQL Server 2000 SP3 und Windows SharePoint Services finden Sie im Handbuch für Windows SharePoint Administratoren und den Installationsanweisungen der verschiedenen Anwendungen.

Erwägungen bei der Installation von Windows SharePoint Services

Vor oder während der Installation von Microsoft Windows SharePoint Services müssen Sie bestimmte Entscheidungen treffen. Einige dieser Entscheidungen, wie z.B. die Wahl des verwendeten Datenbanktyps, können zu einem späteren Zeitpunkt mit geringem Arbeitsaufwand geändert werden. Andere Entscheidungen, wie z.B. der verwendete Benutzerkontomodus können nur geändert werden, indem Sie Windows SharePoint Services entfernen und neu installieren. Wenn Sie Windows SharePoint Services in einer großräumigen Umgebung wie z.B. einer Serverfarm installieren, ist es von besonderer Wichtigkeit von Anfang an die richtigen Entscheidungen zu treffen. Bevor Sie Windows SharePoint Services installieren, sollten Sie die folgenden Punkte sorgfältig in Erwägung ziehen.

Auswahl eines Benutzerkontomodus

Bei der Installation von Windows SharePoint Services müssen Sie den gewünschten Modus für Benutzerkonten festlegen. Windows SharePoint Services kann mit folgenden Kontenmodi ausgeführt werden:

  1. Domänenkontomodus (empfohlen)

    Dieser Modus wird innerhalb von Unternehmen verwendet, um Benutzern mit vorhandenen Microsoft Windows Domänenkonten den Zugriff zu gewähren.

  2. Active Directory-Kontenerstellungsmodus

    Dieser Modus wird von Internetanbietern zum Erstellen eindeutiger Konten für Kunden im Active Directory-Verzeichnisdienst verwendet.

Hinweis: Insight wurde unter Verwendung des Domänenkontomodus getestet und wir empfehlen, die Implementation auch mit diesem Modus durchzuführen.

Die Modi dürfen nicht gemischt werden. Sie müssen entweder den Domänenkontomodus oder den Active Directory-Kontenerstellungsmodus auswählen. Der Unterschied zwischen den beiden Modi besteht in der Methode zur Erstellung von Benutzerkonten. Beim Domänenkontomodus verwenden Sie existierende Domänenbenutzerkonten. Beim Active Directory-Kontenerstellungsmodus werden Konten automatisch in der von Ihnen angegebenen Active Directory-Organisationseinheit erstellt. Bei beiden Modi wird die gleich Methode zum Verwalten von Benutzern einer Site verwendet. Sie fügen diese der Site mithilfe deren vorhandener Domänen- oder Active Directory-Konten hinzu und weisen sie Sitegruppen zu, um ihnen die zur Verwendung der Site erforderlichen Berechtigungen zu erteilen.

Die Auswahl des Benutzerkontomodus ist eine einmalige Entscheidung, die sich darauf auswirkt wie die Konfigurationsdatenbank für Ihren Server oder Ihre Serverfarm erstellt wird. Da Benutzerkonten nach Erstellung der Konfigurationsdatenbank nicht mehr geändert werden können, ist dieser Schritt bei Verwendung von SQL Server eine der ersten Entscheidungen nach der Installation.

Weitere Informationen über Benutzerkontenmodi finden Sie im Abschnitt Managing Users and Cross-Site Groups im Handbuch für Windows SharePoint Services Administratoren.

http://www.microsoft.com/technet/treeview/default.asp?url=/technet/prodtechnol/windowsserver2003/deploy/confeat/wssAGabs.asp.

Wenn Sie sich im Active Directory-Kontenerstellungsmodus befinden stehen Ihnen bestimmte administrative Aufgaben in den HTML-Administrationsseiten nicht zur Verfügung. So können Sie z.B. keine übergeordnete Website erstellten, nicht die selbstbedienende Siteerstellung aktivieren und Sites keine Benutzer aus den Hauptverwaltungsseiten hinzufügen. Um diese Aktionen im Active Directory-Kontenerstellungsmodus durchführen zu können, müssen Sie die Befehlszeile oder das Objektmodell verwenden. Weitere Informationen finden Sie im Abschnitt Using the Object Model to Manage Windows SharePoint Services des Handbuchs für Windows SharePoint Services Administratoren http://www.microsoft.com/technet/treeview/default.asp?url=/technet/prodtechnol/windowsserver2003/deploy/confeat/wssAGabs.asp.

Die Gruppenrichtlinie Minimales Kennwortalter des Domänencontrollers muss auf 0 Tage eingestellt sein. Wenn Sie diese Einstellung nicht vornehmen, können Benutzer ihre Kennwörter nur dann ändern, wenn sie Administratorrechte auf den Server haben. Informationen über das Festlegen der Gruppenrichtlinie Minimales Kennwortalter finden Sie in der Online-Hilfe für Microsoft Windows 2003.

Auswahl eines Datenbanktyps

Insight erfordert für den SharePoint-Speichermechanismus SQL Server 2000 SP3 oder eine neuere Version. Insight kann nicht mit Windows SharePoint Services auf WMSDE ausgeführt werden.

Die Standardinstallation von Windows SharePoint Services verwendet Windows MSDE. Bei Verwendung dieser SharePoint Setup-Option wird kein zur Suche verwendbarer Eigenschaftsindex erstellt und die maximale Anzahl von Benutzerverbindungen ist auf zehn beschränkt.. Insight benötigt den Eigenschaftsindex, um festzustellen welche Dateien in das lokale Cache des Benutzers kopiert werden sollen. Aus diesem Grund kann Insight nicht mit einer WMSDE-Installation ausgeführt werden.

Hinweis: Sie müssen Windows SharePoint Services mit SQL Server 2000 SP3 für den Speichermechanismus installieren.

Auswahl des Authentifizierungstyps für SQL Server

Wenn Sie sich entscheiden SQL Server mit Windows SharePoint Services zu verwenden, müssen Sie auch die Authentifizierungsmethode auswählen, die für Verbindungen zwischen Windows SharePoint Services und den SQL Server-Datenbanken verwendet werden soll. Sie können für diese Verbindungen entweder die Windows-Authentifizierung oder die SQL Server-Authentifizierung verwenden.

  1. Die Windows-Authentifizierung bietet mehr Sicherheit, da sie für die Verbindung mit der SQL Server-Datenbank von den Domänenanmeldeinformationen eines IIS-Anwendungspools abhängig ist. Der Benutzernamen und das Kennwort werden nicht zwischen Servern gesendet, sondern werden durch den IIS-Anwendungspool abstrahiert. (empfohlen)

  2. Die SQL Server-Authentifizierung verfügt ?9ber einen geringeren Grad an Sicherheit, da bei Verbindung mit der Datenbank der Benutzername und das Kennwort für das Datenbankadministratorkonto unverschlüsselt von Server zu Server gesendet wird.

Sie treffen die Entscheidung über die Datenbankauthentifizierung nach der Installation, wenn Sie sich das erste Mal mit den SQL Server-Datenbanken verbinden.

Weitere Informationen über die Sicherheit finden Sie im Abschnitt Windows SharePoint Services Security Model des Handbuchs für Windows SharePoint Services Administratoren http://www.microsoft.com/technet/treeview/default.asp?url=/technet/prodtechnol/windowsserver2003/deploy/confeat/wssAGabs.asp.

Weitere Informationen über Authentifizierungsmethoden für SQL Server 2000 finden Sie in der Dokumentation zu SQL Server 2000.

Hinweis: Wir empfehlen die Implementation mit der Windows-Authentifizierung für SQL Server durchzuführen, da sie den höchsten Grad an Sicherheit bietet.

Auswahl einer IIS Anwendungspoolkonfiguration

Anwendungspools wurden im Internet-Informationsdienst (IIS) mit Version IIS 6 eingeführt. Mithilfe von Anwendungspools können Sie zur Ausführung Ihrer Webanwendungen einen isolierten Prozess verwenden. Jeder Anwendungspool hat eindeutige Anmeldeinformationen auf dem Server, damit Sie identifizieren können, welche Anwendungen welche Aktionen durchführen. Wenn die Anwendung fehlschlägt, wirkt sich dies nicht auf andere Anwendungen aus, die ebenfalls ausgeführt werden.

Windows SharePoint Services unterstützt das neue Anwendungspoolmodell von IIS 6. Wenn Sie Ihren Server oder Ihre Serverfarm konfigurieren, können Sie unter folgenden Optionen auswählen:

  1. Ein Anwendungspool für den administrativen virtuellen Server.

    Der administrative virtuelle Server muss immer über einen eigenen separaten Anwendungspool verfügen.

  1. Gemeinsame Anwendungspools für alle virtuellen Server die Websites verwalten.

    Sie können den gleichen Anwendungspool für alle anderen virtuellen Server festlegen, die Sie in Windows SharePoint Services verwenden. In diesem Fall verlieren Sie jedoch den Sicherheits- und Fehlerschutz, den Ihnen die Verwendung mehrerer Anwendungspools bietet. Auf nur einem virtuellen Server ausgeführte Anwendungen können möglicherweise Daten aus dem virtuellen Server einer anderen Anwendung lesen oder schreiben und wenn ein virtueller Server fehlschlägt, schlagen alle anderen auch fehl.

  1. Separate Anwendungspools für alle virtuellen Server die Websites verwalten.

    Mit separaten Anwendungspools für jeden virtuellen Server genießen Sie den vollen Sicherheits- und Fehlerschutz, der Ihnen durch Anwendungspooldateien geboten wird. Wenn ein virtueller Server fehlschlägt, wirkt sich dies nicht auf die anderen aus Eine in einem gesonderten Anwendungspool ausgeführte Anwendung kann nicht die Daten einer anderen Anwendung lesen, wenn sich diese Anwendung auf einem anderen virtuellen Server befindet. Separate Anwendungspools stellen jedoch höhere Anforderungen an die Verwaltung, da für jeden Anwendungspool gesonderte Domänenkonten erstellt und gepflegt werden müssen.

  1. "Gemeinsame" Anwendungspools für alle virtuellen Server, die die gleichen Websites verwalten.

    In einer Serverfarm-Umgebung können Sie auch festlegen, dass die gleichen Anwendungspoolkonten für alle virtuellen Server verwendet werden, die die gleichen Websites verwalten. Wenn Ihre Serverfarm beispielsweise drei Server enthält, von denen jeder mindestens über einen virtuellen Server verfügt der die gleiche Website verwaltet (http://www.Beispiel.com/site), können Sie für alle diese Site verwaltenden virtuellen Server das gleiche Anwendungspoolkonto verwenden. Auf diese Weise brauchen Sie sich für diese Gruppe mit Websites nur einen Satz mit Anmeldeinformationen zu merken und können außerdem in Ihrer Serverfarm Aufgaben über einen ganzen Satz von virtuellen Servern hinweg erledigen.

Hinweis: Wenn Sie diesen Konfiguration wählen, müssen Sie für das Anwendungspoolkonto unbedingt ein Domänenkonto verwenden.

Sie geben den für Ihren administrativen virtuellen Server zu verwendenden Anwendungspool an, wenn Sie Windows SharePoint Services auf einen Server installieren und die Konfigurationsdatenbank festlegen. Sie legen alle anderen zu verwendenden Anwendungspools fest, wenn Sie einen virtuellen Server auf diesem Server erweitern. Weitere Informationen zu Anwendungspools finden Sie im IIS 6.0-Hilfesystem.

Installation des Insight Servers vor dem Erstellen von Sites

Die Installation von Insight Server erweitert die Menüs der Dokumentbibliothek, um die Insight Webparts hinzuzufügen und erhöht außerdem die von SharePoint unterstützte maximale Zeichenfolgenlänge. Sie müssen beim Betrieb in einer Webfarm auf jedem Windows SharePoint Server-Webserver Insight Server installieren oder beim Betrieb eines einzelnen Servers den Windows SharePoint Server, um die standardmäßigen Sitevorlagen zu aktualisieren bevor Sie SharePoint irgendwelche sitespezifischen Anpassungen oder SharePoint-Sites hinzufügen.

Hinweis: Jegliche vor der Installation von Insight Server erstellten Sites, einschließlich der Standardwebsite, können nicht als Insight-Dokumentbibliotheken verwendet werden.

Hinzufügen von Insight-Erweiterungen zu benutzerdefinierten Vorlagen

Insight Server ändert die SharePoint- und SharePoint Portal Server-Standardvorlagen, um die Webparts sowie die Unterstützung von Zeichenfolgen mit mehr als 255 Zeichen hinzuzufügen. Wenn Sie Ihre eigenen Sitevorlagen erstellen oder eines der SharePoint-Sprachenpakete laden, müssen Sie die Vorlagen folgendermaßen ändern, um die Unterstützung von Insight hinzuzufügen:

  1. Schließen Sie IE stoppen Sie IIS.

  2. Suchen Sie als erstes alle ONET.XML-Dateien und erstellen Sie eine Sicherungskopie. Bearbeiten Sie anschließend jede ONET.XML, die sich unter $:\Programme\Gemeinsame Dateien\Microsoft Shared\Web Server Extensions\60\TEMPLATE\1033\SITE DEFINITION NAME\XML befindet.

Ersetzen Sie

<Projekttitel="Team Web Site" ListDir="Lists" xmlns:ows="Microsoft SharePoint">

mit

<Projekttitel="Team Web Site" ListDir="Lists" xmlns:ows="Microsoft SharePoint" CustomJSUrl="/_layouts/[%=System.Threading.Thread.CurrentThread.CurrentUICulture.LCID%]/SolidEdgeInsight_custom_ows.js">

  3. Starten Sie IIS neu.

Microsoft SharePoint Einschränkungen

Die Kapazität von SharePoint Services wird ebenfalls durch die Anzahl der Objekte begrenzt, die in einem bestimmten Bereich erstellt werden können, wie etwa die Anzahl von Dokumenten pro Ordner. Die Bereicheinschränkungen in Windows SharePoint Services sind keine harten vom System durchgesetzten Grenzen. Sie stellen vielmehr praktische für eine akzeptable Leistung auferlegte Einschränkungen dar. Sie können diese Grenzen zwar überschreiten, die daraus resultierende Leistung kann jedoch möglicherweise nicht akzeptabel sein.

Die folgende Tabelle enthält eine Liste der Objekte in Windows SharePoint Services sowie eine Beschreibung von deren Einschränkungen.

Objekt | Bereich | Grenze | Kommentar
Site-Auflistung | Datenbank | 50.000 | Der Gesamtdurchsatz nimmt mit Zunahme der Anzahl von Site-Auflistungen ab. Bei 10.000 Site-Auflistungen beträgt der Durchsatz 90% des Höchststandes. Bei 50.000 Site-Auflistungen beträgt der Durchsatz 70% des Höchststandes.
Websites | Website | 10.000 | Die Leistung der Schnittstelle zum Aufzählen von untergeordneten Sites einer bestimmten Website lässt nach 1.000 untergeordneten Sites erheblich nach.
Websites | Site-Auflistung | 2 Millionen | Sie können eine sehr große Gesamtzahl von Websites erstellen, indem Sie die untergeordneten Sites verschachteln. Beispiel: 1.000 untergeordnete Sites mit je 1.000 untergeordneten Sites ergeben 1.001.000 Websites.
Dokumente | Ordner | 10.000 | Die Leistung der Schnittstellen zum Aufzählen von Dokumenten in einem Ordner lassen nach tausend Einträgen erheblich nach.
Dokumente | Bibliothek | 2 Millionen | Sie können sehr große Bibliotheken erstellen, indem Sie Ordner verschachteln.
Sicherheitsmandanten | Website | 2.000 | Die Größe der Zugriffssteuerung ist auf einige tausend Sicherheitsmandanten (Benutzer und Gruppen in der Website) beschränkt.
Benutzer | Website | 2 Millionen | Sie können Ihrer Website Millionen von Menschen hinzufügen, indem Sie zum Verwalten der Sicherheit anstelle von einzelnen Benutzern Microsoft Windows-Sicherheitsgruppen verwenden.
Einträge | Liste | 10.000 | Die Leistung der Schnittstelle zum Aufzählen von Einträgen lässt nach einigen tausend Einträgen erheblich nach.
Webparts | Seite | 100 | Seiten mit mehr als 100 Webparts werden langsam gerendert.
Webpart-Personalisierung | Seite | 10.000 | Seiten mit mehr als einigen tausend Benutzerpersonalisierungen werden langsam gerendert.
Listen | Website | 10.000 | Die Leistung der Schnittstelle zum Aufzählen von Listen und Bibliotheken in einer Website lässt nach einigen tausend Einträgen erheblich nach.
Dokumentgröße** | Datei | 50 MB | Die Leistung bei der Dateispeicherung nimmt mit Zunahme der Dateigröße ab. Die obere Grenze beträgt zirka 50 MB. Diese Grenze wird vom System durchgesetzt, kann jedoch vom Administrator geändert werden.

**Die maximale von Microsoft empfohlene Dateigröße beträgt 50 MB, wir haben jedoch Dateien mit einer Größe von bis zu 230 MB getestet, ohne Fehler oder einen ungewöhnlichen Leistungsabfall festzustellen.

Die folgenden Zeichen werden in Windows SharePoint Services nicht unterstützt:

/ \ : * ? " < > | # { } % & ~ oder Tabulatorzeichen und mehrere Punkte.

Hinweis: Falls der Name einer Datei, eines Ordner oder einer URL in Ihrer ursprüngliche Site eines dieser Zeichen enthält, wird es durch einen Unterstrich (_) ersetzt. Mehrere aufeinanderfolgende Punkte werden durch einen einzigen Punkt ersetzt. Bei widersprüchlichen Umbenennungsänderungen werden dem Datei- oder Ordnernamen gegebenenfalls zusätzliche Ziffern angehängt. Ordnernamen dürfen nicht mit einem Unterstrich (_) beginnen.

Ändern der virtuellen Servereinstellungen

Es gibt mehrere Optionen die Sie für jeden virtuellen Server ändern müssen, er für Insight-Dateien verwendet werden soll.

Maximale Uploadgröße

SharePoint beschränkt die Größe von Dateien standardmäßig auf 50 MB. Um diese Einstellung zu ändern, gehen Sie auf die Seite für allgemeine virtuelle Servereinstellungen des virtuellen Servers und ändern Sie die Option Maximale Uploadgröße. In diesem Beispiel wurde die maximal Uploadgröße auf 250 MB geändert, die größte einzelne Datei, die von uns getestet wurde.

Wenn Sie die Grenze festgelegt haben wählen Sie im unteren Bereich der Seite OK, um Ihre Änderungen zu speichern.

Ereignishandler

Wenn Sie den von Insight und Microsoft bereitgestellten SharePoint-Arbeitsablauf verwenden, müssen Sie Ereignishandler für den virtuellen Server aktivieren. Sie können diese Option aktivieren, indem Sie sie auf der Seite zum Ändern der virtuelle Servereinstellungen des virtuellen Servers wie unten abgebildet einschalten.

Volltextsuche aktivieren

Um Volltextsuchen mit WSS 2 und Insight durchführen zu können, müssen Sie die Volltextsuche und Indexkomponenten auf den WSS-Administratorseiten aktivieren. Sie können diese Option aktivieren, indem Sie im Abschnitt Komponentenkonfiguration der WSS Hauptverwaltungsseite die Option Volltextsuche konfigurieren wählen.

Zugriff auf die Site oder Dokumentbibliothek

Das Dashboard stellt die Webschnittstelle zu Ihrer Solid Edge-Site oder Dokumentbibliothek dar. Es gibt zwei Methoden, um auf Ihre Site oder Dokumentbibliothek zuzugreifen:

  1. Internet Explorer

  2. Dialogfeld Öffnen in Solid Edge

Hinweis: Sie können zum Öffnen von Solid Edge-Dokumenten den Internet Explorer verwenden.

Wenn die Site oder Dokumentbibliothek nicht automatisch den Internet Explorer aktiviert, können Sie sich mit Ihrer Solid Edge-Site (DashBoard) über die Webordnerablage verbinden, die Sie zuvor festgelegt haben. Geben Sie die Webablage ein, die Sie unter Verwendung Ihres Server-Knotennamens erstellt haben.

In diesem Beispiel würden Sie http://hsvnt315/engineering eingeben. Dies ist nur ein Beispiel; der Name in Ihrer Installation weicht ab.

Das standardmäßige Internet Explorer-Dashboard sieht etwa folgendermaßen aus:

Sie können die Option Netzwerkressource hinzufügen unter Netzwerkumgebung verwenden, um sich mit Ihrer Solid Edge-Dokumentbibliothek zu verbinden.

Hinweis: Wenn Sie Microsoft Windows XP verwenden, müssen Sie vor dem Hinzufügen einer Netzwerkressource die Web Client-Dienste deaktivieren.

So deaktivieren Sie Web Client-Dienste

  1. Klicken Sie in der Systemsteuerung auf Verwaltung und anschließend auf Dienste.

  2. Klicken Sie mit der rechten Maustaste auf den Listeneintrag WebClient und wählen Sie Eigenschaften.

  3. Ändern Sie den Starttyp auf Deaktiviert.

  4. Ändern Sie den Dienststatus auf Angehalten.

  5. Klicken Sie auf OK.


Installation der Insight Server Software

In den folgenden Arbeitsschritten installieren Sie die Insight Server-Software auf Ihrem Server.

Einrichten des Servers

  1. Gehen Sie auf Ihrer Solid Edge V15-CD zum Ordner Software\Insight\InsightServer V15\Program und doppelklicken Sie auf setup.exe. Der Insight Server V15 - InstallShield-Assistent wird eingeblendet. Dieser Assistent ist Ihnen bei der Installation der Insight Server-Software behilflich. Klicken Sie im Assistenten auf die Schaltfläche OK.

  2. Wählen Sie auf der Seite Lizenzvereinbarung die Option Ich akzeptiere die Bedingungen der Lizenzvereinbarung, und klicken Sie dann auf Weiter.

  3. Geben Sie auf der Seite Benutzerinformationen die Angaben zu Ihrem Unternehmen ein, und klicken Sie dann auf Weiter.

  4. Geben Sie die Ablage für die Insight Server-Dateien an und klicken Sie auf Weiter.

  5. Windows Installer bezieht diesen Schritt mit ein, damit Sie das Add-In Webparts und Dienste von Insight installieren können, mit dem Sie Solid Edge-Dokumente in einem SharePoint-Dashboard anzeigen können. Klicken Sie zum Installieren des Add-Ins auf die Schaltfläche neben dem Namen des Add-Ins und wählen Sie nur diese oder alle untergeordneten Komponenten zur Installation aus.

  6. Klicken Sie auf Installieren und anschließend auf Fertig stellen.

Nach dem Laden von SharePoint und Insight Server, müssen Sie einige Vorbereitungen treffen, bevor Sie mit Solid Edge arbeiten können.

Hinzufügen und konfigurieren einer Dokumentbibliothek

Sie fügen jetzt eine Dokumentbibliothek für einen Solid Edge-Benutzer hinzu und konfigurieren diese, damit darin Dokumente gespeichert werden können.

  1. Gehen Sie im Internet Explorer zur entsprechenden Website und klicken Sie auf Erstellen.

  2. Klicken Sie im Abschnitt Dokumentbibliotheken auf Seite Seite erstellen auf den Eintrag Dokumentbibliotheken.

  3. Geben Sie auf der Seite Neue Dokumentbibliothek einen Namen für die Dokumentbibliothek ein, legen Sie die gewünschten Optionen für die Dokumentbibliothek fest und klicken Sie auf Erstellen.

Erstellen der erforderlichen Eigenschaften auf dem Server

Bevor Sie Solid Edge zusammen mit einer SharePoint-Site verwenden können, müssen Sie als Administrator die erforderlichen Eigenschaften für jede Dokumentbibliothek auf dem Server erstellen und die Benutzer sowie die Rollen für den Zugriff auf bestimmte Ordner auf der Site einrichten.

Durch Erstellen der erforderlichen Eigenschaften, werden der Dokumentbibliothek automatisch die erforderlichen Solid Edge-Eigenschaften hinzugefügt.

  1. Klicken Sie im Startmenü auf Programme, dann auf Solid Edge Insight Server V15 und schließlich auf Arbeitsbereichseditor. Geben Sie im Dialogfeld Erstellen erforderlicher Server-Eigenschaften den Namen der zuvor erstellten URL für die Dokumentbibliothek ein und klicken Sie anschließend auf Erstellen. In diesem Beispiel lautet der Name der Dokumentbibliothek SEDocLib1. Dieser Vorgang dauert einige Minuten.

Wenn die Eigenschaften erfolgreich erstellt wurden, wird ein Dialogfeld eingeblendet.

  2. Klicken Sie in diesem Dialogfeld auf OK.

Hinweis: Sie können Zeit sparen, indem Sie die erforderlichen Eigenschaften erstellen, Ihre benutzerdefinierten Eigenschaften hinzufügen und die Dokumentbibliothek als Vorlage speichern. Sie können diese Vorlage anschließend zum Erstellen Ihrer anderen Dokumentbibliotheken verwenden. Sie können auch Sites als Vorlagen speichern.

Hinzufügen von neuen Spalten

Spalten können als benutzerdefinierte Eigenschaften verstanden werden, die die Informationen zu Objekten in einer Dokumentbibliothek speichern.

So fügen Sie eine neue Spalte hinzu

  1. Klicken Sie auf der Homepage der Website auf eine Dokumentbibliothek.

  2. Klicken Sie im Anschnitt Aktionen auf der Seite <Name der Dokumentbibliothek> auf Einstellungen und Spalten ändern.

  3. Klicken Sie im Abschnitt Spalten auf der Seite <Name der Dokumentbibliothek> anpassen auf Neue Spalte erstellen.

  4. Geben Sie in das Feld Spaltenname auf der Seite <Name der Dokumentbibliothek> Spalte hinzufügen einen Namen für die Spalte ein und währen Sie einen Informationstyp für die Spalte aus. Die Spalte entspricht einer benutzerdefinierten Eigenschaft.

Hinweis: Stellen Sie beim Hinzufügen von neuen Spalten sicher, dass der Typ für alle Dokumentbibliotheken gleich ist, da ansonsten Übereinstimmungsprobleme bei den Eigenschaften auftreten können. Wenn Sie Ihren Dokumentbibliotheken beispielsweise die Spalte Dokumentnummer hinzufügen, muss deren Typ in allen Bibliotheken übereinstimmen.

  5. Im Abschnitt Optionale Spalteneinstellungen können sie die Option Diese Spalte muss Informationen enthalten aktivieren, wenn Sie festlegen wollen, dass für diese Spalte eine Eingabe erforderlich ist. Stellen Sie sicher, dass die Option Zu Standardansicht hinzufügen aktiviert ist.

  6. Klicken Sie auf OK.


Insight-Webkomponenten

Insight basiert auf Microsoft SharePoint, einer Plattform zur Informationsfreigabe, mit der Sie Metadaten (z.B. CAD-Dateien) und Produktdaten (z.B. Dateiattribute) verwalten können. Die Insight Webparts ermöglichen eine echte Integration von Insight und SharePoint. Dadurch können andere Benutzer (ohne Solid Edge) Solid Edge-Dokumente auf einer SharePoint-Webpartseite anzeigen.

Hinweis: Die Webkomponenten von Insight sind als Add-In verfügbar, das Sie während der Installation im InstallShield-Assistenten von Insight Server auswählen müssen. Ohne dieses Add-In sind Sie nicht in der Lage, Solid Edge-Dokumente auf einer SharePoint-Webpartseite anzuzeigen.

Im Lieferumfang von Insight Server sind drei Webparts enthalten, mit denen Sie Solid Edge-Daten für andere Benutzer (ohne Solid Edge) offen legen können:

  1. Stücklistenansicht

  2. Eigenschaftsansicht

  3. Grafische Ansicht

Diese Komponenten werden in der virtuellen Servergalerie auf dem SharePoint Server installiert, aus der sie auf die Webpartseite gezogen dort abgelegt werden können, die die Solid Edge Insight Webparts verwaltet.

Mit der Stücklistenansicht können Sie eine Komponentenliste aller Solid Edge-Dokumente oder eine Explosionsdarstellung der Stückliste einer Baugruppe anzeigen. Wenn Sie eine Komponente in der Stücklistenansicht auswählen, werden die Eigenschaftsansicht und die grafische Ansicht automatisch mit den Informationen der ausgewählten Komponente aktualisiert.

Es gibt verschiedene Methoden zum Ändern der Stücklistenansicht. Sie können auf eine Spalte doppelklicken, um die Einträge in der Stückliste zu sortieren. Sie können einen Spaltentitel auswählen und anschließend durch Ziehen und Ablegen des Titels die Reihenfolge der Spalten ändern. Sie können auf die rechte Maustaste klicken, um ein Kontextmenü einzublenden, mit dem Sie die Schriftart ändern, die Eigenschaften sortieren, Text suchen und Spalten formatieren können.

Die Stücklistenansicht ist besonders hilfreich, wenn Sie Auszüge erstellen müssen. Sie können Informationen in der Stücklistenansicht hervorheben, und diese anschließend in eine Microsoft Excel-Kalkulationstabelle kopieren und einfügen.

Die Eigenschaftsansicht zeigt die Profil- und die Systemeigenschaften für eine ausgewählte Stücklistenkomponente an. Sie können die Eigenschaften in der Liste wie in der Stücklistenansicht sortieren.

Die grafische Ansicht zeigt eine grafische Darstellung der ausgewählten Stücklistenkomponente an. Die grafische Ansicht stellt Ihnen Befehle zur Verfügung, mit denen Sie die Ansicht manipulieren können. Sie können Ansichten des Modells einpassen, verschieben, drehen, vergrößern und verkleinern.

Wenn Sie die Webkomponente Grafische Ansicht verwenden, um Assembly-, Part-, Sheet Metal- oder Weldment-, PCF-, DXF- oder DWG-Dokumente anzuzeigen, werden die Dokumente automatisch vom Server in das lokale Insight-Cache heruntergeladen. in den meisten Fällen befindet sich dieses Cache auf dem Systemlaufwerk. Unter Windows 2000 befindet es sich üblicherweise unter <Systemlaufwerk>:\Dokumente und Einstellungen\<Benutzername>\Anwendungsdaten\Microsoft\MSDAIPP\OffLine. Dieses Cache wird im Laufe der Zeit je nach der Anzahl und Größe der angezeigten Dokumente relativ groß. Deshalb sollten Sie diesen Ordner regelmäßig prüfen und gegebenenfalls Dokumente löschen, um zu vermeiden, dass Ihnen der Speicherplatz ausgeht. Mithilfe der Registerkarte Dateiablage im Dialogfeld Optionen können Sie die Ablage für das Insight-Cache ändern.

Um einen der oben aufgeführten unterstützten Dokumenttypen in den Webparts anzuzeigen, klicken Sie auf den Menüeintrag “Eigenschaften/Grafik/Stückliste anzeigen” im Kontextmenü des Dokuments in der SharePoint-Dokumentbibliothek oder im verschachtelten Ordner, in dem das Dokument sich befindet. Daraufhin wechselt SharePoint zu der Webpart-Seite, wobei dieses Dokument als Kontext-URL für die Anzeige der Webparts dient.

Voraussetzungen für die Verwendung von Webparts

Element

Geliefert

Version 1.1 von .NET Framework

Wenn dieses Element nicht vorhanden ist, zeigt Webparts eine Fehlermeldung an, die eine Verknüpfung zur selbstextrahierenden .EXE auf dem Insight Server enthält.

Das entsprechende Sprachenpaket (wenn .NET Framework nicht englisch).

Wie oben, jedoch mit der Ausnahme, dass keine Meldung oder Verknüpfung erscheint wenn der Benutzer bereits über die entsprechende Version von Framework verfügt, ungeachtet dessen, ob das Sprachenpaket geladen wurde oder nicht.

Microsoft XML 3.0 Parser

Wird, falls nicht bereits vorhanden, automatisch beim Herunterladen der Internetkomponenten auf die Maschine des Benutzers geliefert.

Eine der folgenden Client Softwares:

  1. Solid Edge

  2. Insight Connect

  3. Solid Edge Viewer

Hat der Benutzer keine der oben aufgeführten Softwares geladen, veranlasst Webparts das automatische Herunterladen vom Insight Server und die Ausführung des Setups.

Installieren der Webkomponenten

Die Insight Webkomponenten sind in einer CAB-Datei SEWebParts.CAB verpackt, die im Ordner InsightServerInstallDir\Web Components geliefert wird. Eine Stapelverarbeitungsdatei mit dem Namen InstallWP.BAT wird im gleichen Ordner geliefert und muss ausgeführt werden, um die Webkomponenten ordnungsgemäß in SharePoint zu installieren. Vor Ausführung der Stapelverarbeitungsdatei müssen Sie unbedingt sicherstellen, dass die mit SharePoint gelieferte ausführbare Datei STSADM.EXE in der Umgebungsvariablen PATH aufgeführt ist. Diese Datei befindet sich gewöhnlich unter <%Systemlaufwerk%>:\Programme\Gemeinsame Dateien\Microsoft Shared\web server extensions\60\BIN. Wenn Sie die Umgebungsvariable PATH nicht modifizieren wollen, müssen Sie die Datei InstallWP.BAT ändern, um den vollen Pfad für STSADM.EXE einzubeziehen.

Erstellen der Webpart-Seite

Die Webpart-Seite ist eine besonderer Typ von Containerdokument in SharePoint, das einen oder mehrere Webparts verwaltet. Weitere Informationen zur Erstellung einer Webpart-Seite lesen Sie bitte in der Dokumentation von SharePoint nach. Wir empfehlen dringend, die Webpart-Seite in einer Dokumentbibliothek auf einer separaten Website zu erstellen, damit Sie Benutzer, Gruppen, Berechtigungen und Authentifikation ohne Auswirkungen auf Ihre Insight-Websites und -Dokumentbibliotheken ändern können. Dies ist wichtig, da die Webparts ein breiteres Publikum haben werden, als die technischen Zeichner und Ingenieure, die an den Dokumenten arbeiten. Es ist auch nicht nötig in dieser Bibliothek die erforderlichen Solid Edge-Eigenschaften zu erstellen, es sei denn Sie haben vor hier Solid Edge-Dokumente zu speichern.

Zum Schluss muss der Administrator sicherstellen, dass alle Benutzer und Gruppen, die Anzeigeberechtigungen für Webparts benötigen der entsprechenden Webpart-Seite hinzugefügt werden.

Aktivieren der angepassten Menüerweiterung

Nachdem Sie das Webpart-Seitendokument erstellt haben, muss der Insight-Administrator die URL dieses Dokuments wie z.B. http://<server>/sites/WPPSite/WPPDocLib/WebParts.aspx der Datei SolidEdgeInsight_custom_ows.js als Wert der Skriptvariablen L_Path_to_SEWebPartPage_Text hinzufügen. Diese Datei wird gewöhnlich unter <%Systemlaufwerk%>:\Programme\Gemeinsame Dateien\Microsoft Shared\web server extensions\60\TEMPLATE\LAYOUTS\<lang id> auf dem SharePoint Server installiert. Auf diese Weise kann der Administrator die angepasste Menüerweiterung für Solid Edge-Dokumente aktivieren, z.B. den Menüeintrag Eigenschaften/Grafik/Stückliste anzeigen, der den Benutzer von beliebigen Solid Edge Dokumenten (mit Ausnahme von .CFG-Dateien in einer Insight-Dokumentbibliothek) zu dieser Webpart-Seite dirigiert.

Hinzufügen von Webparts

Sobald die Webpart-Seite fertig gestellt ist, kann der Administrator zu dieser Seite gehen. Der Administrator kann von der Webpart-Seite aus auf Gemeinsame Seite modifizieren zeigen, anschließend auf Webparts hinzufügen zeigen und dann auf Durchsuchen klicken, um die Werkzeuge zum Hinzufügen von Webparts zu öffnen. Klicken Sie auf Virtual Server Gallery, um auf den Speicherort der Insight-Webparts zuzugreifen. Ziehen Sie beliebige Stücklisten-, Eigenschafts- oder Grafik-Webparts von der Webpart-Liste und legen Sie diese auf der Webpart-Seite am gewünschten Ort ab. Klicken Sie anschließend im Werkzeugabschnitt auf Schließen. Die Webparts sind jetzt bereit zum Gebrauch.

Ändern der Webpart-Einstellungen

Webparts verfügen über eine allgemeine Ansicht und eine persönliche Ansicht. Die allgemeine Ansicht gilt für alle Benutzer und erfordert höhere Sicherheitsrechte, um geändert werden zu können. Die persönliche Ansicht gilt nur für die einzelnen Benutzer. Die drei Solid Edge-Webparts verfügen über eingebettete Steuerungen und weisen die eingebaute Flexibilität zum Speichern individueller Benutzerpräferenzen für bestimme Steuerungseinstellungen auf. Folgende Einstellungen sind konfigurierbar:

  1. Stücklisten- und Eigenschaften-Webparts

  2. Steuerungshöhe in Pixeln

  3. Steuerungsbreite in Pixeln

  4. Legt fest, ob die Steuerung beim Laden der Webpart-Seite reduziert oder erweitert wird.

  5. Grafik-Webpart

  6. Steuerungshöhe in Pixeln

  7. Steuerungsbreite in Pixeln

  8. Legt fest, ob die Steuerung beim Laden der Webpart-Seite reduziert oder erweitert wird.

  9. Hintergrundfarbe für 2D- und 3D-Dokumente

  10. Einblenden von EdgeBar

Sie können diese Einstellungen konfigurieren, indem Sie im Webpart-Pulldownmenü auf Mein Webpart klicken, um die Bearbeitungswerkzeuge aufzurufen. Ändern Sie hier die Einstellungen im Abschnitt Steuerungseinstellungen.

Damit alle Benutzer die Webpart-Steuerungseinstellungen gemäß deren persönlicher Präferenz modifizieren können, muss der Administrator sie in eine Websitegruppe einbeziehen, deren persönliche Berechtigungen das Aktualisieren von persönlichen Webparts einschließen.

Ändern des Dokumentinhaltes, ohne die Webpart-Seite zu verlassen

Sie werden gewöhnlich zur Webpart-Seite geleitet, indem Sie den Menüeintrag “Eigenschaften/Grafik/Stückliste anzeigen" im Kontextmenü des Dokuments zusammen mit der URL für das Dokument (die Kontext-URL für die Webpart-Seite) verwenden. Wenn Sie mehrere Solid Edge-Dokumente in den Webkomponenten anzeigen wollen, ist es sehr mühsam zu jedem einzelnen Dokument zu navigieren und anschließend über das Kontextmenü des Dokuments zurück zur Webpart-Seite geleitet zu werden. Wenn Sie bereits eine Liste mit auf der Webpart-Seite anzuzeigenden URLs haben, ist es wesentlich einfacher, die in der Adressleiste des Internet Explorers angezeigte URL der Webpart-Seite direkt zu modifizieren, um den Dokumentinhalt zu ändern, ohne die Webpart-Seite zu verlassen.

Das Format für die URL der Webpart-Seite die Webkomponenten mit Kontext anzeigt lautet wie folgt:

<web part page url>?SEURL=<solid edge document url>

Ersetzen Sie den Teil der URL für die Webpart-Seite, der sich auf der rechten Seite des Gleichheitszeichens "=" befindet (siehe Beispiel oben) mit der neuen URL und aktualisieren Sie die Seite, um die Informationen für ein anderes Dokument in den Webkomponenten anzuzeigen. Die Webkomponenten zeigen jetzt das neue Dokument an.


SharePoint - Übersicht

Insight arbeitet zusammen mit Microsoft SharePoint, um Ihnen bei der Verwaltung von Solid Edge-Dokumenten zu helfen. Microsoft SharePoint ist ein Werkzeug zur Dokumentverwaltung, das Sie bei der Suche, Verwaltung und gemeinsamen Nutzung von Daten auf einer umfangreichen, anpassbaren Dashboardsite unterstützt, mit deren Hilfe Benutzer auf Inhalte innerhalb eines Unternehmens zugreifen, diese bearbeiten und verwalten können. SharePoint lässt sich nahtlos in andere Werkzeuge wie Windows Explorer und Webbrowser integrieren, um Ihnen bei der Verwaltung Ihrer Dokumente zu helfen.

Der Server verwendet Werkzeuge wie Microsoft Management Console, Sicherheitsbenutzer und -gruppen des Betriebssystems, Such- und Indizierungsalgorithmen sowie ein ausführlich dokumentiertes Objektmodell zum Speichern und Verwalten von Dokumenten.


Solid Edge-Eigenschaften, die synchronisiert werden

Nachfolgend werden die Solid Edge-Dateieigenschaften angezeigt, die synchronisiert werden. Sie können diese Eigenschaften im Dialogfeld Dateieigenschaften in Solid Edge oder im Internet Explorer anzeigen.

Name der Eigenschaftssätze | Eigenschaftsname | Wo im Dialogfeld Eigenschaften? | Wird die Eigenschaft standardmäßig vom SharePoint Server indiziert? | SharePoint-Eigenschaftsname für die Synchronisierung
Datei-Info | Titel | Datei-Info, Registerkarte | ***Ja | Titel
Datei-Info | Thema | Datei-Info, Registerkarte | ***Ja | Thema
Datei-Info | Autor | Datei-Info, Registerkarte | ***Ja | Autor
Datei-Info | Stichwörter | Datei-Info, Registerkarte | ***Ja | Stichwörter
Datei-Info | Kommentar | Datei-Info, Registerkarte | ***Ja | Kommentar
Datei-Info | Vorlage | Datei-Info, Registerkarte | *Ja | Vorlage
Datei-Info | Zuletzt gespeichert von | Statistik, Registerkarte (nur in SE) Datei-Info, Registerkarte (nur in Explorer) | *Ja | Zuletzt gespeichert von
Datei-Info | Revisionsnummer | Datei-Info, Registerkarte (nur in Explorer) | *Ja | Ignoriert. Die Eigenschaft "Revisionsnummer" im Eigenschaftssatz Projekt wird mit dem Eigenschaftsnamen "Revisionsnummer" synchronisiert.
Datei-Info | Gesamtbearbeitungszeit | Datei-Info, Registerkarte (nur in Explorer) | **Entfällt | Gesamtbearbeitungszeit
Datei-Info | Zuletzt gedruckt | Datei-Info, Registerkarte (nur in Explorer) | **Entfällt | Zuletzt gedruckt
Datei-Info | Erstellungsdatum | Datei-Info, Registerkarte (nur in Explorer) | Nein | Erstellungsdatum
Datei-Info | Zuletzt gespeichert | Datei-Info, Registerkarte (nur in Explorer) | Nein | Zuletzt gespeichert
Datei-Info | Seitenanzahl | Datei-Info, Registerkarte (nur in Explorer) | **Entfällt | Seitenanzahl
Datei-Info | Wortzahl | Datei-Info, Registerkarte (nur in Explorer) | **Entfällt | Wortzahl
Datei-Info | Zeichenanzahl | Datei-Info, Registerkarte (nur in Explorer) | **Entfällt | Zeichenanzahl
Datei-Info | Seitenansicht | Nicht angezeigt | **Entfällt | Ignoriert. Eigenschaftstyp wird nicht von SharePoint unterstützt.
Datei-Info | Anwendungsname | Statistik, Registerkarte (nur in SE) / Datei-Info, Registerkarte (nur in Explorer) | *Ja | Anwendungsname
Datei-Info | Sicherheit | Nicht angezeigt | *Ja | Sicherheit
Projekt | Dokumentnummer | Projekt, Registerkarte | Nein | Dokumentnummer
Projekt | Projektname | Projekt, Registerkarte | Nein | Projektname
Projekt | Revisionsnummer | Projekt, Registerkarte | Nein | Revisionsnummer
Dokument-Info | Kategorie | Datei-Info, Registerkarte | ***Ja | Kategorie
Dokument-Info | Format | Datei-Info, Registerkarte (nur in Explorer) | **Entfällt | Präsentationsformat
Dokument-Info | Byte | Datei-Info, Registerkarte (nur in Explorer) | **Entfällt | Byte
Dokument-Info | Zeilen | Datei-Info, Registerkarte (nur in Explorer) | **Entfällt | Zeilen
Dokument-Info | Absätze | Datei-Info, Registerkarte (nur in Explorer) | **Entfällt | Absätze
Dokument-Info | Folien | Datei-Info, Registerkarte (nur in Explorer) | **Entfällt | Folien
Dokument-Info | Notizblätter | Datei-Info, Registerkarte (nur in Explorer) | **Entfällt | Notizblätter
Dokument-Info | Ausgeblendete Folien | Datei-Info, Registerkarte (nur in Explorer) | **Entfällt | Ausgeblendete Folien
Dokument-Info | Multimedia-Clips | Datei-Info, Registerkarte (nur in Explorer) | **Entfällt | Multimedia-Clips
Dokument-Info | Manager | Datei-Info, Registerkarte | ***Ja | Manager
Dokument-Info | Firmenname | Datei-Info, Registerkarte | ***Ja | Firma
Erweiterte Datei-Info | Gespeichert mit Anwendung | Statistik, Registerkarte (nur in SE) | Nein | Gespeichert mit Anwendung
Erweiterte Datei-Info | Dateigröße | Nicht angezeigt | Nein | Dateigröße
Erweiterte Datei-Info | Anzahl der Blätter | Nicht angezeigt | Nein | Anzahl der Blätter
Info | Anzahl der Objekte | Nicht angezeigt | Nein | Anzahl der Objekte
Info | Dokument-ID | Nicht angezeigt | Nein | Dokument-ID
Info | Status | Status, Registerkarte | Nein | Status
Mechanische Modellierung | Material | Projekt, Registerkarte | Nein | Material
Anpassen | Beliebige benutzerdefinierte Eigenschaft | Anpassen, Registerkarte | Nein | Name der benutzerdefinierten Eigenschaft.
*Ja | Falls die Eigenschaft in der Dokumentbibliothek definiert wurde, wird sie von SharePoint indiziert.
***Ja | Die Eigenschaft wird standardmäßig im Dokumentprofil (Basisdokument) definiert. Sie sind in allen SharePoint-Profilen enthalten und können nicht gelöscht werden.
**Entfällt | Die Eigenschaften sind spezifisch für Microsoft Word- oder Excel-Dokumenten und sind nicht auf Solid Edge-Dokumente anwendbar.

Hinweis: In Windows SharePoint Services 2003 dürfen Eigenschaften Leerzeichen enthalten. Leerzeichen in Eigenschaften waren in SharePoint Portal Server 2001 nicht gestattet.

Wenn der Name einer benutzerdefinierten Eigenschaft mit dem angezeigten Namen in SharePoint übereinstimmt, dann wird die Eigenschaft synchronisiert.

Hinweis: Es gibt keine Solid Edge-Eigenschaften, die mit der SharePoint-Eigenschaft "Beschreibung" synchronisiert werden können. Sie können eine benutzerdefinierte Eigenschaft für "Beschreibung" erstellen und mit SharePoint synchronisieren, um dieses Problem zu vermeiden.

Erstellen von erforderlichen Eigenschaften

Insight enthält einen Satz mit acht Eigenschaften, die zum Verwalten von Solid Edge-Dokumenten in SharePoint erforderlich sind.

  1. SEDocID

  2. SELinkData

  3. SERevised From

  4. SEStatus

  5. SEStatusUser

  6. SELastKnownLocation

  7. SERevisionLevel

  8. SERevisionRoot

Die Eigenschaft SEDocID enthält Informationen, die von Insight zum Verwalten von Verknüpfungen gebraucht werden. Jedes von SharePoint verwaltete Dokument verfügt über eine eindeutige ID. Insight speichert die Verknüpfungsdaten in der Eigenschaften SEDocID. Falls Insight keine Verknüpfungen in der relativen Pfadstruktur eines verwalteten Dokuments findet, wird versucht, das Dokument anhand seiner eindeutigen ID ausfindig zu machen.

Die Eigenschaft SELinkData enthält eine Textdarstellung aller Verknüpfungen im Dokument. Diese Eigenschaft wird bei Verwendungsnachweissuchen und Auszügen verwendet. Sie dient außerdem zum Feststellen der Dokumente, die beim Herunterladen in das lokale Cache kopiert werden sollen.

Die Eigenschaft SERevisedFrom enthält den Namen des Dokuments, von dem die ausgewählte Dokumentrevision erstellt wurde. Diese Eigenschaft wird ausgefüllt, wenn Sie den Befehl Aktion wählen: Revisionieren im Revision Manager wählen.

Die Eigenschaft SEStatus enthält den Status des Dokuments, der auf der Registerkarte des Dialogfelds Dateieigenschaften festgelegt wird.

Die Eigenschaft SEStatusUser enthält den Namen des letzten Benutzers, der den Status des Dokuments auf der Registerkarte des Dialogfeld Dateieigenschaften geändert hat.

Die Eigenschaft SELastKnownLocation enthält die URL, in der das Dokument beim letzten Einchecken gespeichert wurde. Sie wird jedes Mal, wenn Sie ein Dokument einchecken aktualisiert und hilft Ihnen verschobene Dateien zu finden.

Die Eigenschaft SERevisionRoot ist die SEDocID für das erste revidierte Dokument in der Revisionshistorie. Auf diese Weise ist es einfacher alle revidierte Dateien ausgehend von einem gemeinsamen Stamm zu finden.

Die Eigenschaft SERevisionLevel enthält Informationen die den Ort einer Datei innerhalb der Revisionsstruktur festlegen, so dass bei Verwendung von Revisionsregeln beim Öffnen der Datei die korrekte Revision geöffnet wird.

Hinzufügen von erforderlichen Eigenschaften

Bevor Sie Solid Edge Insight verwenden können, müssen Sie als Administrator den Satz mit erforderlichen Eigenschaften auf dem Server erstellen, und die Benutzer sowie die Rollen für den Zugriff auf bestimmte Ordner in der verwalteten Bibliothek einrichten.

Gehen Sie hierzu folgendermaßen vor:

  1. Klicken Sie im Startmenü auf Programme, dann auf Solid Edge Insight Server und schließlich auf Arbeitsbereichseditor.

  2. Geben Sie im Dialogfeld Erstellen erforderlicher Server-Eigenschaften den Namen Ihrer Dokumentbibliothek ein, und klicken Sie auf Erstellen.

Wenn die Eigenschaften erfolgreich erstellt wurden, wird ein Dialogfeld eingeblendet.

  3. Klicken Sie in diesem Dialogfeld auf OK.


Sites, Dokumentbibliotheken und Dashboards

Während der Installation von Windows SharePoint Services wird automatisch eine Dashboardsite und eine Dokumentbibliothek erstellt.

Sites oder Dokumentbibliotheken auch als verwaltete Bibliotheken bekannt, stellen eine Sammlung von Ordnern, Verwaltungswerkzeugen, Kategorien und indizierten Daten dar. In der Dokumentbibliothek oder auf der Site können Sie Dokumente erstellen, prüfen und veröffentlichen.

Sie können sich mit der Site oder Dokumentbibliothek über einen Webbrowser oder Office-Anwendungen verbinden.

Das Dashboard stellt einen zentrale Zugriffsstelle für das Suchen und Verwalten von Daten dar. Zum Suchen von Daten und Ausführen von Verwaltungsaufgaben können Sie einen Webbrowser verwenden. Über das Dashboard können Sie nach Dokumenten suchen und Daten abonnieren.

Hinweis: Sie können zum Öffnen von Solid Edge-Dokumenten den Internet Explorer verwenden.

Insight kann nicht auf der Standardsite ausgeführt werden, da diese erstellt wird, bevor der Insight Server die Sitevorlagen modifiziert. Aus diesem Grund funktionieren Webparts und Arbeitsabläufe auf der Standardseite nicht. Sie müssen für alle Arbeiten mit Insight untergeordnete Sites verwenden.


Dokumentverwaltung mit Solid Edge Insight

Solid Edge Insight verfügt über Funktionen, die Sie bei der Verwaltung Ihrer Dokumente unterstützen:

  1. Rollenbasierte Zugriffssteuerung

  2. Erstellung von eigenen Rollen

  3. Versionskontrolle

Als Administrator können Sie Rollen zuweisen, um den Zugriff auf Ihre Dokumente zu steuern. Vor dem Zuweisen einer Rolle sollten Sie sich überlegen, in welchem Umfang Sie einem Benutzer Zugriff auf die Dokumente gewähren wollen. Wenn Sie z.B. vermeiden möchten dass ein Benutzer einen Satz mit Dokumenten ändert, weisen Sie ihm für den entsprechenden Ordner die Rolle Leser zu. Der Benutzer kann auf diese Weise die Dokumente anzeigen, jedoch keine Änderungen daran vornehmen.

Solid Edge Insight zeichnet den Dokumentverlauf auf, um Ihnen bei der Verfolgung von am Dokument vorgenommenen Änderungen zu helfen. Wenn Sie ein Dokument ändern wollen, können Sie es auschecken und damit anderen Benutzern den Schreibzugriff auf das Dokument verweigern, während Sie es bearbeiten. Wenn Sie mit der Bearbeitung fertig sind, checken Sie das Dokument wieder ein, um das Dokument für andere Benutzer verfügbar zu machen. Sobald Sie ein Dokument einchecken, weist Insight dem Dokument eine neue Versionsnummer zu und archiviert das alte Dokument in der verwalteten Bibliothek. Wenn Sie ein Dokument auschecken, rufen Sie immer die neueste Version des Dokuments ab, es sei denn, Sie stellen eine ältere Version wieder her und machen diese zur aktuellen Version.

Rollen in SharePoint

Microsoft SharePoint 2001 stellte Ihnen drei Benutzerrollen zur Verfügung:

  1. Leser

  2. Autor

  3. Koordinator

Die Funktionen dieser Rollen waren bisher fixiert und konnten nicht angepasst werden. Mit Windows SharePoint Services 2003 stehen Ihnen fünf standardmäßige Benutzergruppen zur Verfügung:

  1. Gast

  2. Leser

  3. Teilnehmer

  4. Webdesigner

  5. Administrator

Die Rollen zwischen den beiden Versionen verteilen sich etwa folgendermaßen:

Microsoft SharePoint 2001 - Rolle | Windows SharePoint Services 2003 - Gruppe
Leser | Leser
Autor | Teilnehmer
Koordinator | Administrator

Ein Gast entspricht in in etwa einem Leser, der jedoch von Liste zu Liste festgelegt wird. Diese Rolle kann einem Benutzer nicht auf Websiteebene zugewiesen werden.

Ein Webdesigner ist der Administratorgruppe sehr ähnlich, kann jedoch weder Benutzer verwalten noch neue Websites erstellen.

Windows SharePoint Services 2003 führt außerdem das Konzept von Benutzerrechten ein. Benutzerrechte sind gesonderte Berechtigungen wie Durchsuchen, Löschen und Bearbeiten, die kombiniert werden können, um Windows SharePoint Services 2003-Gruppen zu erstellen. Da Gruppen sich aus einzelnen Rechten zusammensetzen, können die Standardgruppen in Windows SharePoint Services 2003 geändert werden. So können Sie beispielsweise die Löschberechtigung aus der Teilnehmergruppe entfernen, um die Benutzer am Löschen von Dateien zu hindern. Sie können außerdem neue Gruppen erstellen.

Weitere Informationen finden Sie im Handbuch für Microsoft Windows SharePoint Services 2003 Administratoren.

Ein weiterer Unterschied zwischen Microsoft SharePoint 2001 und Windows SharePoint Services 2003 besteht in der Art und Weise wie Berechtigungen im System zugewiesen werden. In Microsoft SharePoint 2001 war es möglich Benutzerberechtigungen auf Ordnerebene zuzuweisen. In Windows SharePoint Services 2003 werden Berechtigungen und Gruppen auf der Stammwebsite festgelegt, die in untergeordneten Websites oder Dokumentbibliotheken überschrieben werden können.

Hinweis: Sie können den Windows SharePoint Services 2003-Standardgruppen Benutzer nur auf Bibliotheksebene zuweisen.

Falls Sie die in Microsoft SharePoint 2001 vorhandene ordnerspezifische Funktionalität nachahmen wollen, müssen Sie für jeden Satz von eindeutigen Berechtigungen eine neue Site und Dokumentbibliothek erstellen. Weitere Informationen hierzu finden Sie im Dokument Insight von Microsoft SharePoint 2001 zu Windows SharePoint Services 2003 migrieren.

Verwalten von Benutzern und Websitegruppen

Sie müssen über Administratorrechte verfügen, um Ordnern, Sites oder Dokumentbibliotheken Rollen zuweisen zu können.

So fügen Sie eine Websitegruppe hinzu

  1. Wählen Sie im Internet Explorer die entsprechende Site aus.

  2. Klicken Sie auf Websiteeinstellungen.

  3. Klicken Sie auf der Seite Websiteeinstellungen auf Zur Siteverwaltung.

  4. Klicken Sie auf der Seite Verwaltung im Abschnitt Benutzer und Berechtigungen auf die Option Websitegruppen verwalten.

  5. Klicken Auf der Seite Websitegruppen verwalten auf die entsprechende Websitegruppe.

  6. Klicken Auf der Seite Websitegruppen verwalten auf die Option Websitegruppe hinzufügen.

  7. Geben Sie im Abschnitt Name und Beschreibung der Seite Websitegruppe hinzufügen einen Namen und eine Beschreibung für die Websitegruppe ein.

  8. Aktivieren Sie im Abschnitt Rechte die entsprechenden Optionen für die Websitegruppe und klicken Sie anschließend auf Websitegruppe erstellen. Aktivieren Sie unbedingt die Option Verzeichnisse durchsuchen im Abschnitt Websiterechte, um sicherzustellen, dass Sie Websiteverzeichnisse durchsuchen können.

So fügen Sie einer Websitegruppe einen Benutzer hinzu

  1. Wählen Sie im Internet Explorer die entsprechende Website aus.

  2. Klicken Sie auf Websiteeinstellungen.

  3. Klicken Sie im Abschnitt Verwaltung der Seite Websiteeinstellungen auf die Option Benutzer verwalten.

  4. Wählen Sie auf der Seite Benutzer verwalten die Benutzer aus, die Sie der Websitegruppe hinzufügen wollen und klicken Sie anschließend auf Websitegruppen der ausgewählten Benutzer bearbeiten.

  5. Klicken Sie im Abschnitt Websitegruppenmitgliedschaft der Seite Websitegruppenmitgliedschaft bearbeiten auf die Websitegruppe, der Sie den Benutzer hinzufügen wollen und anschließend auf OK.


SharePoint-Datentypen

SharePoint 2003 fügt mehrere neue Datentypen und Formatierungsoptionen hinzu. Sie können diese Informationen zwar vom SharePoint-Dashboard aus sehen, die folgenden Datentypen und Formateinstellungen sind jedoch nicht innerhalb der Solid Edge-Anwendung sichtbar:

Datentyp/Formateinstellung | Auswirkung in Solid Edge
Datum/Uhrzeit – Nur Datum | Solid Edge zeigt das vollständige Datum und den Zeitstempel an.
Nachschlagetabelle | Eigenschaften dieses Typs werden in Solid Edge nicht angezeigt.
Berechnet | Eigenschaften dieses Typs werden in Solid Edge nicht angezeigt.
Zahl Minimum/Maximum | Diese Einschränkungen werden von Solid Edge nicht beachtet.
Anzeige als Prozentsatz | Diese Anzeigeeinstellung wird von Solid Edge nicht beachtet. Der gespeicherte Wert wird als standardmäßiger numerischer Wert angezeigt. Beispiel: 33% wird als 0,33 angezeigt.

Microsoft hat ebenfalls die Behandlung von Auswahleigenschaften geändert. In SharePoint 2001 konnten Sie mehrere Ausfüllwerte hinzufügen. Seit SharePoint 2003 können Sie der Dokumentbibliothek pro Auswahleigenschaft lediglich einen Ausfüllwert hinzufügen.

Listen und Dokumentbibliotheken können in Windows SharePoint Services lediglich eine bestimmte Anzahl von Feldern oder Spalten enthalten. Die maximalen Werte für Felder und Spalten sind:

  1. 64 Textfelder, einschließlich der folgenden Feldtypen:

  2. Einzelne Textzeile

  3. Auswahlliste

  4. Bild

  5. 16 Nachschlagetabellenfelder

  6. 16 Datum/Uhrzeit-Felder

  7. 16 Ja/Nein-Felder

  8. 32 Zahlenfelder

  9. 32 Mehrzeilige Textfelder

Hinweis: SharePoint und Insight fügen einer Dokumentbibliothek erforderliche Felder hinzu, so dass die Grenzwerte tatsächlich niedriger als die oben aufgeführten sind.


Dokumentversionierung

Mithilfe der Dokumentversionierung können Sie mehrere Versionen eines Dokuments behalten. Wenn Sie eine an einem Dokument vorgenommene Änderung rückgängig machen müssen, können Sie die vorherige Version des Dokuments wieder herstellen und mit Ihrer Arbeit fortfahren. Bei Windows SharePoint Services-Dokumentbibliotheken ist die Versionierung standardmäßig deaktiviert. Sie können diese Option aktivieren, indem Sie zur Seite Dokumenbibliothekseinstellungen gehen und unter Dokumentversionen Ja wählen.

Hinweise: In SharePoint 2001 konnten Administratoren die Anzahl der Versionen begrenzen. In SharePoint 2003 ist die Anzahl der Versionen unbegrenzt. Microsoft liefert derzeit keine automatisierten Werkzeuge zum gleichzeitigen Entfernen von veralteten Versionen aller in einer Dokumentbibliothek enthaltenen Dokumente. Sie können dies jedoch von Datei zu Datei durchführen.

Wegen der extrem hohen Speicherplatzerfordernissen bei unbegrenzten Dokumentversionen empfehlen wir die Versionierung erst dann zu verwenden, wenn ein Dienstprogramm zum Festlegen von Versionsgrenzen oder eine automatisierte Methode zum Entfernen von Versionen aller in einer Dokumentbibliothek enthaltenen Dokumente zur Verfügung steht.


Hinzufügen von Solid Edge-Dokumenten zu einer verwalteten Bibliothek

Mit Insight Connect können Sie einer verwalteten Bibliothek mehrere Dokumente und mit Solid Edge einzelne Dokumente hinzufügen.

Hinzufügen von Dokumenten mit Insight Connect

Mit dem Befehl Zur Bibliothek hinzufügen im Menü Verwalten in Insight Connect können Sie Ihre nicht verwalteten Solid Edge-Dokumente in eine verwaltete Bibliothek laden. Zum Hinzufügen von Dateien und Ordnern benötigen Sie Autorenberechtigung. Sie können ein einzelnes Dokument, mehrere Dokumente oder auch einen ganzen Ordner hinzufügen.

Hinzufügen von Dokumenten mit Solid Edge

Sie können beim Erstellen eines neuen Dokuments den Befehl Speichern unter verwenden, um der verwalteten Bibliothek neue Solid Edge-Dokumente hinzuzufügen. Wählen Sie im Feld Ablage des Dialogfelds Speichern unter eine verwaltete Bibliothek aus. Wenn Sie das Dokument schließen, wird es der Bibliothek hinzugefügt.

Wenn Sie der Bibliothek ein Solid Edge-Dokument hinzufügen, werden auch alle mit diesem Dokument verknüpften Dokumente dieser Bibliothek hinzugefügt. Beim Hinzufügen eines Ordners, werden der verwalteten Bibliothek auch alle in diesem Ordner enthaltenen Dokumente hinzugefügt.

Wenn Sie einer verwalteten Bibliothek einen Ordner hinzufügen, wird die Ordnerstruktur in der Bibliothek dupliziert. Wenn Sie z.B. C:\MeineDokumente\Teile wählen, wird in der verwalteten Bibliothek ein neuer Ordner mit dem Namen Teile erstellt. Nachdem Sie einer verwalteten Bibliothek Dokumente und Ordner hinzugefügt haben, können Sie die Ordnerstruktur mit Insight Connect ändern, ohne hierbei die Verknüpfungen zu beschädigen.

Es ist nicht möglich, Dokumente mit dem Befehl Zur Bibliothek hinzufügen von einer Bibliothek in eine andere zu verschieben. Verwenden Sie stattdessen den Revision Manager, um Dokumente von einer verwalteten Bibliothek in eine andere zu verschieben.

Sicherheit, Genehmigungen, Profile und Typen für alle beim Hinzufügen neu erstellten Ordner werden vom jeweils übergeordneten Ordner übernommen. Wenn Sie beispielsweise dem verwalteten Ordner Washers das Solid Edge Part-Dokument flat050.par hinzufügen, erbt das Teil die Eigenschaften des Ordners Washers.

Direkte und indirekte Dokumente

Alle Dokumente die Sie zum Hinzufügen zur verwalteten Bibliothek auswählen, werden als direkte Dokumente bezeichnet. Diese direkten Dokumente können Verknüpfungen zu anderen Dokumenten aufweisen oder andere Dokumente referenzieren, die wiederum als indirekte Dokumente bezeichnet werden. Wenn Sie also in einer Baugruppe nur ein Assembly-Dokument zum Hinzufügen in eine verwaltete Bibliothek auswählen, gelten alle mit diesem Assembly-Dokument verknüpften Dokumente als indirekte Dokumente. Ebenso stellen eine in einem Part-Dokument enthaltene Teilkopie sowie ein in einer Zeichnung referenziertes Teil indirekte Dokumente dar.

Hinzufügen von XpresRoute-Dokumenten

Wenn Sie ein Rohrteil in XpresRoute erstellen, wird eine Part-Datei mit der Rohrgeometrie erstellt. Außerdem enthält das Rohrteil eine umgekehrte Verknüpfung mit der Baugruppe, in der das Rohr erstellt wurde.

Nehmen Sie z.B. an, dass Sie eine neue Baugruppe und die XpresRoute-Umgebung öffnen und anschließend ein Rohr erstellen. Die umgekehrte Verknüpfung kann erst dann beseitigt werden, wenn Sie die Baugruppe speichern. Speichern Sie die Baugruppe bevor Sie ein Rohr in einer verwalteten Bibliothek erstellen, um die umgekehrte Verknüpfung zu beseitigen.

Reparieren Sie die Verknüpfungen, bevor Sie ein vorhandenes Rohrteil zu einer verwalteten Bibliothek hinzufügen. Verwenden Sie den Befehl Unterbrochene Verknüpfungen suchen in Insight Connect im Menü Extras unter Verknüpfungsverwaltung, um den temporären Namen der Baugruppe zu finden. Führen Sie anschließend den Befehl Verknüpfungen neu definieren im Menü Extras unter Verknüpfungsverwaltung aus, um den temporären Dateinamen mit dem vollständigen Pfad der Verknüpfung zu ersetzen.

Nehmen Sie beispielsweise an, dass Sie den Befehl Unterbrochene Verknüpfungen suchen ausführen und der Befehl einem temporären Namen für die Baugruppe Assembly1a.asm angibt. Mit dem Befehl und den Dialogfeldern Verknüpfungen neu definieren können Sie diese unterbrochene Verknüpfung beseitigen. Geben Sie im zweiten Dialogfeld Verknüpfungen neu definieren im Feld Aktueller Verknüpfungspfad assem1.asm ein. Geben Sie im Feld Verknüpfungspfad neu definieren den vollständigen Pfad für die Assembly-Datei ein, z.B. D:\Projects\P105\Assembly1a.asm. Daraufhin wird die Verknüpfung repariert.

Vor dem Hinzufügen von Dokumenten zu einer verwalteten Bibliothek

Bevor Sie einer verwalteten Bibliothek Dokumente hinzufügen, müssen Sie folgende Vorbereitungen treffen:

  1. Suchen und berichtigen aller unterbrochenen Verknüpfungen

  2. Suchen nach doppelten Dokumentnamen

  3. Entfernen von nicht verwalteten Dokumenten

  4. Prüfen auf ungültige Dokumentnamen

Es ist möglich, einer verwalteten Bibliothek Dokumente mit unterbrochenen Verknüpfungen hinzuzufügen. Beachten Sie aber, dass Dokumente mit unterbrochenen Verknüpfungen mehr Zeit zum Öffnen beanspruchen. Mit dem Befehl Zur Bibliothek hinzufügen im Menü Extras unter Verknüpfungsverwaltung in Insight Connect können Sie einen Test durchführen, um festzustellen, welche Dateien unterbrochene Verknüpfungen und ungültige Zeichen auf einer einzelnen Ebene enthalten. Stellen Sie sicher, dass die Option Unterbrochene Verknüpfungen zulässig auf der Registerkarte Verwalten im Dialogfeld Optionen deaktiviert ist, bevor Sie den Befehl Zur Bibliothek hinzufügen ausführen, falls Sie keine Dokumente mit unterbrochenen Verknüpfungen zur Bibliothek hinzufügen wollen. Falls Sie die Option Unterbrochene Verknüpfungen zulässig deaktivieren und der Test Dokumente mit unterbrochenen Verknüpfungen findet, dann zeigt ein Dialogfeld für Fehlermeldungen eine Liste unterbrochener Verknüpfungen an. Außerdem enthält es die Anweisung zum Reparieren der unterbrochenen Verknüpfungen bevor Sie die Dokumente zur Bibliothek hinzufügen. Falls Sie die Option Unterbrochene Verknüpfungen zulässig aktivieren, wird das Dialogfeld Testen fertig gestellt eingeblendet, sobald der Test fertig gestellt wurde, damit Sie die Dokumente zur Bibliothek hinzufügen und den Status der Dokumente in "Eingecheckt" ändern können.

Während der Test die Dokumentenliste durchsucht, werden nicht nur unterbrochene Verknüpfungen gesucht. Der Test durchsucht Ordner und Dokumente auf ungültige Zeichen. Wenn ein Dokument zur Bibliothek hinzugefügt wird, werden ungültige Zeichen durch einen Unterstrich ( _ ) ersetzt und der aktuelle Zeitstempel zum Dateinamen hinzugefügt. Verknüpfungen, die auf den alten Namen verweisen, werden aktualisiert, um auf den neuen Namen zu verweisen. Wenn ein Ordner ein ungültiges Zeichen im Namen enthält, dann müssen Sie den Ordner umbenennen und die Verknüpfungen, die auf den alten Ordnernamen verweisen, aktualisieren, bevor Sie die Dateien in Insight importieren. Weitere Informationen zum Aktualisieren von Verknüpfungen finden Sie in der Hilfe zum Befehl Verknüpfungen neu definieren. Der Test meldet einen Fehler, wenn der lokale Cache-Pfad für die angegebene Datei oder den Cookie-Dateinamen und Pfad 256 Zeichen übersteigt.

Wir empfehlen Ihnen, den Test zum Identifizieren von unterbrochenen Verknüpfungen durchzuführen. Sie können aber auch nach unterbrochenen Verknüpfungen suchen, bevor Sie Dokumente zur Bibliothek hinzufügen. Mit dem Befehl Unterbrochene Verknüpfungen suchen, den Sie in Insight Connect im Menü Extras unter Verknüpfungsverwaltung finden, können Sie eine Liste von Dateien mit unterbrochenen Verknüpfungen erstellen. Sie können nach unterbrochenen Verknüpfungen in einzelnen Dokumenten oder einer kompletten Ordnerstruktur einschließlich der Unterordner suchen. Der Befehl Unterbrochene Verknüpfungen suchen erstellt eine Textdatei, die alle unterbrochenen Verknüpfungen sowie mögliche Ersetzungen derselben auflistet. Dies ist besonders bei einer großen Anzahl von unterbrochenen Verknüpfungen hilfreich. Mithilfe der Registerkarte Dateiablage im Dialogfeld Optionen können Sie die Ablage für diese Textdatei bestimmen. Sie können außerdem auf die Schaltfläche Ansicht im Dialogfeld Unterbrochene Verknüpfungen suchen - Auszug klicken, um die Textdatei anzuzeigen.

Je nach Anzahl der Dateien mit unterbrochenen Verknüpfungen, gibt es verschiedene Methoden zur Berichtigung. Wenn Sie viele Dateien mit unterbrochenen Verknüpfungen haben, können Sie sie mit dem Befehl Verknüpfungen neu definieren berichtigen. Wenn Sie nur wenige Dateien mit unterbrochenen Verknüpfungen haben, können Sie sie mit Revision Manager oder dem Befehl Verknüpfungen bearbeiten berichtigen oder in Solid Edge öffnen.

Sie können einer verwalteten Bibliothek zwar doppelte Dokumente hinzufügen, doppelte Dokumentnamen dürfen jedoch nicht im selben Ordner vorhanden sein. Mit dem Befehl Doppelte Dokumentnamen suchen, den Sie in Insight Connect im Menü Extras unter Verknüpfungsverwaltung finden, können Sie alle Dokumente suchen, die den gleichen Namen aufweisen. Falls doppelte Dokumentnamen vorhanden sind, müssen Sie sicherstellen, dass Sie der Bibliothek das richtige Dokument hinzufügen.

Der Befehl Doppelte Dokumentnamen suchen erstellt eine Textdatei, die Namen und Ablageorte von doppelten Dokumenten auflistet. Mithilfe der Registerkarte Dateiablage im Dialogfeld Optionen können Sie die Ablage für diese Datei bestimmen.

Wenn Sie einer Bibliothek einen Ordner hinzufügen, werden alle im Ordner enthaltenen Dokumente hinzugefügt, gleichgültig ob Sie diese verwalten wollen oder nicht. Sie sollten daher vor dem Hinzufügen eines Ordner zu einer Bibliothek die Dokumente entfernen, die Sie nicht verwalten wollen. Es kann sich hierbei um Text- oder Protokolldateien handeln, die sich im hinzuzufügenden Ordner befinden.

Der SharePoint Portal Server unterliegt im Bezug auf die unterstützten Sonderzeichen einigen Einschränkungen. Es ist äußerst wichtig, dass Sie Ihre lokalen Ordner auf ungültige Dokumentnamen durchsuchen, bevor Sie sie der verwalteten Bibliothek hinzufügen.

Mit Ausnahme der folgenden Einschränkungen werden erweitertes ASCII, Doppelbyte-Zeichensätze (DBCS) und Unicode für alle Sprachen unterstützt:

Einschränkungen bei Ordner- und Dokumentnamen

  1. Der SharePoint Portal Server unterstützt die gleichen Benennungsregeln für Ordner und Dokumente wie das Dateisystem. Ordner und Dokumente dürfen alle Unicode-Zeichen enthalten, mit Ausnahme der folgenden:

  2. / \ : * ? " < > | # { } % & ~ oder Tabulatorzeichen und mehrere aufeinanderfolgende Punkte.

  3. Falls der Name einer Datei, eines Ordner oder einer URL in Ihrer ursprüngliche Site eines dieser Zeichen enthält, wird es durch einen Unterstrich (_) ersetzt. Mehrere aufeinanderfolgende Punkte werden durch einen einzigen Punkt ersetzt. Bei widersprüchlichen Umbenennungsänderungen werden dem Datei- oder Ordnernamen gegebenenfalls zusätzliche Ziffern angehängt. Ordnernamen dürfen nicht mit einem Unterstrich (_) beginnen.

  4. Bei nicht verwalteten Ordner mit ungültigen Zeichen können Sie die Ordner in Windows Explorer umbenennen und anschließend den Befehl Verknüpfungen neu definieren verwenden, um die Verknüpfungen in den Dateien zum Verweis auf den neuen Ordnernamen zu ändern.

Einschränkungen bei Bibliotheksnamen

  1. Bibliotheksnamen dürfen Zeichen aus Standard-ASCII enthalten, mit Ausnahme der folgenden: # : \ ? * < > % / | " { } ~ [ ] Leerzeichen ! ( ) = ; . , @ & +

  2. Der Standard ASCII-Codesatz enthält Zeichen mit den Codes 32-127.

  3. Bibliotheksnamen dürfen nicht länger als 25 Zeichen sein.

Einschränkungen bei Schema-Element- und Spaltennamen

  1. Schema-Element- und Spaltennamen dürfen folgende Zeichen nicht enthalten: # : \ ? * < > % / | " ~

  2. Spaltennamen dürfen Leerzeichen enthalten.

Einschränkungen der Zeichenanzahl bei URLs und Schema-Elementnamen

  1. Uniform Resource Locators (URLs) sind auf 900 Byte beschränkt. Die typische Einschränkung beträgt 254 Unicode-Zeichen, für Englisch. Andere auf Unicode basierte Zeichensätze sind auf 100 Zeichen beschränkt.

  2. Schema-Elementnamen (das Eigenschaftstitelfeld) sind auf 100 beschränkt.

Ordnerzuordnungsdatei

Wenn Dokumente, die Sie der verwalteten Bibliothek hinzufügen wollen, Verknüpfungen zu anderen Dokumenten enthalten (z.B. eine Baugruppe aus mehreren Teilen in verschiedenen Ordnern auf unterschiedlichen Laufwerken), dann wird eine Ordnerzuordnungsdatei erforderlich. Obwohl die verknüpften Dokumente beim Hinzufügen einbezogen werden, muss Insight feststellen können, wo diese Dokumente in der verwalteten Bibliothek eingefügt werden sollen. Sie können die Datei FolderMap.txt im Programmordner verwenden, um festzulegen, wie die verknüpften Dokumente in den nicht verwalteten Ordnern zu den Zielordnern der verwalteten Bibliothek hinzugefügt werden sollen. So können Sie einen Ordner wie C:\PartsLibrary einem verwalteten Ordner zuordnen. Wenn Sie die verknüpften Dokumente hinzufügen, werden alle Dokumente, die sich im Ordner C:\PartsLibrary oder einem untergeordneten Ordner befinden, in der durch die Datei FolderMap.txt festgelegten verwalteten Ordnerstruktur abgelegt.

Die Datei FolderMap.txt befindet sich standardmäßig im Solid Edge-Programmordner. Wenn Sie Solid Edge auf Ihrer Festplatte ausführen, finden Sie die Datei unter C:\Programme\Solid Edge\Program\FolderMap.txt.

Sie können die Software auch anweisen, nach der Datei FolderMap.txt in einem anderen Ordner oder einem Ordner auf einem anderen Computer innerhalb eines Netzwerks zu suchen. Klicken Sie zum Festlegen einer anderen Ablage im Menü Extras auf Optionen. Wählen Sie Insight-Ordnerzuordnung auf der Registerkarte Dateiablage des Dialogfeldes Optionen, und klicken Sie auf Ändern. Sie können jetzt zu dem Laufwerk und Ordner gehen, das die Datei FolderMap.txt enthält. Benutzen Sie zum Bearbeiten dieser Datei einen Texteditor wie z.B. Notepad.

Wenn sich die verknüpften Dokumente im importierten Ordner oder einem seiner untergeordneten Ordner befinden, ist die Datei FolderMap.txt nicht erforderlich. Insight Connect weiß automatisch, wo die verknüpften Dokumente abgelegt werden sollen und kann die Verknüpfungsdaten entsprechend modifizieren. Insight Connect kann außerdem in der verwalteten Bibliothek die Ordner erstellen, in denen die verknüpften Dokumente abgelegt werden.

Wenn sich die verknüpften Dokumente in einem Ordner über dem übergeordneten Dokumentordner oder auf einem anderen Laufwerk befinden, kann Insight nicht automatisch festlegen, wo die verknüpften Dokumente abgelegt werden sollen. In einem solchen Fall ist die Datei FolderMap.txt erforderlich

Bei einer Baugruppe die sich z.B. folgendermaßen zusammensetzt:

Baugruppe - C:\Dir1\Dir2\Assembly1.asm
Teile - C:\Dir1\Dir2\Part1.par
C:\Dir1\Part2.par
D:\Dir1\Dir2\Dir3\Dir4\Part3.par

Wenn Sie die Baugruppe zu http://MeineMaschine/se/docs hinzufügen wollen, muss die Datei FolderMap.txt folgende Einträge enthalten.

Quelle:C:\Dir1 Ziel:http://MeineMaschine/se/docs/Dir3 Quelle:D:\Dir1\Dir2\Dir3\Dir4 Ziel:http://MeineMaschine/se/docs/Dir3/Dir4

Diese Zeichenfolge platziert alle verknüpften Dokumente für die kein neuer Ordner erstellt werden kann, in den Ordner docs der verwalteten Bibliothek. Sie können auch am Ende der Zielzeichenfolge eine neue Ablage anhängen, um einen Ordner zum Speichern der Dokumente zu erstellen.


Solid Edge-Dokumente aus SharePoint löschen

Mit dem Befehl Aus Bibliothek löschen im Menü Verwalten können Sie Dokumente und Ordner auswählen, die Sie aus der Bibliothek mit verwalteten Dokumenten auf Ihrem Server löschen wollen. Sie können ein einzelnes Dokument, mehrere Dokumente oder auch einen ganzen Ordner löschen. Wenn Sie Dokumente und Ordner von Ihrem Server löschen, werden sie auch aus Ihrem lokalen Cache entfernt. Zum Löschen von Dateien und Verzeichnissen benötigen Sie Autorenberechtigung. Wir empfehlen, die Privilegien zum Löschen aus allen Standardbenutzergruppen zu entfernen, so dass Dokument lediglich von einem Administrator gelöscht werden können.

Hinweis: Verwenden Sie zum Löschen von verwalteten Dokumenten immer den Befehl Aus Bibliothek löschen. Wenn Sie verwaltete Dokumente mit dem Windows Explorer oder Internet Explorer löschen, kann es vorkommen, dass zwischen den Solid Edge-Dokumenten bestehende Verknüpfungen aufgehoben werden.

Dokumente und Ordner zum Löschen auswählen

Wenn Sie auf den Befehl Aus Bibliothek löschen klicken, wird das Dialogfeld Aus Bibliothek löschen aufgerufen, in dem Sie Ordner und Dokumente zum Löschen auswählen können. Verwenden Sie die Optionen in diesem Dialogfeld um zu dem verwalteten Ordner mit den Dokumenten zu gelangen, die Sie löschen wollen. Im Dialogfeld Aus Datei löschen werden nur verwaltete Ordner und Dokumente angezeigt. Nicht verwaltete Dokumente oder Ordner werden an dieser Stelle nicht aufgeführt.

Sie legen Dokumente und Ordner zum Löschen fest, indem Sie die entsprechenden Einträge in der Liste auf der linken Seite des Dialogfelds markieren, und sie dann mit der Schaltfläche Hinzufügen in das Feld Ausgewählte Ordner und Dateien auf der rechten Seite des Dialogfelds übertragen. Mit den Schaltflächen Entfernen und Alle entfernen können Sie Einträge aus der Liste Ausgewählte Ordner und Dateien entfernen. Wenn Sie die Liste mit den zu löschenden Objekten zusammengestellt haben, klicken Sie auf OK, um den Löschvorgang einzuleiten.

Unterbrochene Verknüpfungen verhindern

Wenn Sie auf die Schaltfläche OK klicken, führt Solid Edge automatisch zuerst eine Verwendungsnachweissuche durch, um festzustellen, ob die von Ihnen zum Löschen ausgewählten Dokumente Verknüpfungen zu anderen Dokumenten aufweisen. Falls das zu löschende Dokument mit einem anderen Dokument verknüpft ist, das nicht gelöscht wird, erhalten Sie eine entsprechende Meldung und das Dokument wird nicht gelöscht. Wenn Sie z.B. ein Part-Dokument zum Löschen auswählen, dieses jedoch mit einem Draft-Dokument verknüpft ist, das nicht gelöscht wird, ist das Löschen dieses Part-Dokuments nicht möglich. Solid Edge prüft vor dem Löschen von Ordnern nach ob diese leer sind. Nur leere Ordner können gelöscht werden.

Den Suchbereich definieren

Beim Löschen von Dokumenten mit dem Befehl Aus Bibliothek löschen legt die Datei SearchScope.txt fest, welche Ordner in die Verwendungsnachweissuche einbezogen werden sollen. Sie müssen der Datei SearchScope.txt für jede verwaltete Site oder Dokumentbibliothek in Ihrem Unternehmen einen Eintrag hinzufügen. Wenn Sie z.B. eine Site oder Dokumentbibliothek mit dem Namen SolidEdgeWS auf einem Server mit dem Namen server123 erstellen, müssen Sie der Datei folgenden Eintrag hinzufügen: http://server123/SolidEdgeWS. Benutzen Sie zum Bearbeiten dieser Datei einen Texteditor wie z.B. Notepad. Für die Unterordner einer verwalteten Site ist das Hinzufügen von Einträgen nicht erforderlich.

Hinweis: Sie müssen der Datei SearchScope.txt einen Eintrag für jede Dokumentbibliothek hinzufügen.

Die Datei SearchScope.txt ist standardmäßig im Ordner Program von Solid Edge abgelegt. Wenn Sie Solid Edge auf Ihrer Festplatte ausführen, finden Sie die Datei unter C:\Programme\Solid Edge\Program\SearchScope.txt.

Sie können festlegen, dass Solid Edge und Insight Connect in einem anderen Ordner nach der Datei SearchScope.txt suchen sollen, der sich auch auf einem anderen Computer im Netzwerk befinden kann. Klicken Sie zum Festlegen einer anderen Ablage im Menü Extras auf Optionen. Wählen Sie Suchbereich auf der Registerkarte Dateiablage des Dialogfeldes Optionen, und klicken Sie auf Ändern. Sie können dann die Ablage einstellen in der sich die Datei SearchScope.txt befindet.


Den Suchbereich definieren

Beim Löschen von Dokumenten mit dem Befehl Aus Bibliothek löschen legt die Datei SearchScope.txt fest, welche Ordner in die Verwendungsnachweissuche einbezogen werden sollen. Sie müssen der Datei SearchScope.txt für jede verwaltete Website oder Dokumentbibliothek in Ihrem Unternehmen einen Eintrag hinzufügen. Wenn Sie z.B. eine verwaltete Website oder Dokumentbibliothek mit dem Namen SolidEdgeWS auf einem Server mit dem Namen server123 erstellen, würde die Datei SearchScope.txt den folgenden Eintrag enthalten:

http://server123/SolidEdgeWS.

Benutzen Sie zum Bearbeiten dieser Datei einen Texteditor wie z.B. Notepad. Für die Unterordner einer verwalteten Bibliothek ist das Hinzufügen von Einträgen nicht erforderlich.

Die Datei SearchScope.txt ist standardmäßig im Ordner Program von Solid Edge abgelegt. Wenn Sie Solid Edge auf Ihrer Festplatte ausführen, finden Sie die Datei unter C:\Programme\Solid Edge\Program\SearchScope.txt.

Sie können festlegen, dass Solid Edge und Insight Connect in einem anderen Ordner nach der Datei SearchScope.txt suchen sollen, der sich auch auf einem anderen Computer im Netzwerk befinden kann. Klicken Sie zum Festlegen einer anderen Ablage im Menü Extras auf Optionen. Wählen Sie Suchbereich auf der Registerkarte Dateiablage des Dialogfeldes Optionen, und klicken Sie auf Ändern. Sie können dann die Ablage einstellen in der sich die Datei SearchScope.txt befindet. Sie können ein URL nicht als Teil des Pfades für die Datei SearchScope.txt verwenden.


Verwalten von lokalem Cache

Beim Arbeiten mit verwalteten Dokumenten wird von Solid Edge zur Leistungssteigerung ein lokales Cache der angezeigten Dokumente erstellt. Mithilfe der Registerkarte Dateiablage im Dialogfeld Optionen können Sie die Ablage für das lokale Cache bestimmen.

Jedes in Ihr lokales Cache geladene Dokument ist mit einer Cookiedatei assoziiert. Die Cookiedatei enthält Informationen über die tatsächliche Ablage von der das Dokument geladen wurde, den Auscheckstatus des Dokuments sowie den Zeitstempel des Dokuments in der verwalteten Bibliothek zum Zeitpunkt des Herunterladens. Solid Edge erstellt zum Speichern dieser Cookiedateien einen versteckten Ordner mit dem Namen Cookies(Benutzername) unter dem Ordner mit dem lokalen Cache. Wenn Ihr Benutzername z.B. jsmith ist, und Sie geben als Ablage für das lokale Cache D:\verwaltete Dokumente an, erstellt Solid Edge den Ordner D:\verwaltete Dokumente\Cookies(jsmith).

Ein lokales Cache ist schneller und zuverlässiger als ein zugeordnetes Netzlaufwerk. Wenn Sie ein Dokument öffnen, synchronisiert Solid Edge automatisch die Dokumente in der Bibliothek mit den Dokumenten in Ihrem lokalen Cache. Solide Edge prüft im lokalen Cache nach, ob das lokale Dokument mit der Version des Dokuments in der verwalteten Bibliothek übereinstimmt. Anschließend öffnet das Solid Edge die lokale Datei oder kopiert die aktuelle Version von der Bibliothek in Ihr lokales Cache.

Sie können das lokale Cache mit Hilfe des Befehls Cache-Assistent verwalten, der sich im Menü Verwalten befindet. Über das Dialogfeld Cache-Assistent können Sie alle Dokumente der verwalteten Bibliothek synchronisieren, ausgecheckte Dokumente wieder einchecken, Dokumente von der Bibliothek in Ihr lokales Cache laden oder Ihr lokales Cache vollständig leeren.

Sie können die Schaltflächen des Dialogfelds verwenden, um alle Dokumente im lokalen Cache zu verwalten; oder aber auch die Befehle auf dem Kontextmenü von ausgewählten Dokumenten, um einzelne Dokumente zu verwalten. Ähnlich wie bei Windows Explorer können Sie die Strg.-Taste verwenden, um Dokumente in beliebiger Reihenfolge auszuwählen, und die Umschalttaste, um Dokumente in aufeinanderfolgender Reihenfolge auszuwählen.

Mit der Option Anzeigen im Dialogfeld Cache-Assistent können Sie steuern, welche Dokumente in der Liste angezeigt werden. Sie können festlegen ob nur ausgecheckte Dokumente, veraltete Dokumente oder alle im lokalen Cache enthaltenen Dokumente angezeigt werden sollen.

Dokumente der Bibliothek synchronisieren

Die Schaltfläche Alle synchronisieren im Dialogfeld Cache-Assistent überprüft Ihr lokales Cache auf veraltete Dokumente, und lädt dann die aktuelle Dokumentversion aus der verwalteten Bibliothek, um Ihr lokales Cache auf den neuesten Stand zu bringen. Sie können auch den Befehl Synchronisieren auf dem Kontextmenü verwenden, um ausgewählte Dokumente zu synchronisieren.

Hinweis: Beim Arbeiten in der Assembly-Umgebung können Sie die Anzahl der zu synchronisierenden Dateien auf die Dateien beschränken, die im Assembly PathFinder angezeigt werden.

Dokumente in die verwaltete Bibliothek ein- und auschecken

Sie können den Befehl Auschecken auf dem Kontextmenü verwenden, um ein Dokument in der verwalteten Bibliothek zu sperren. Dadurch wird verhindert, dass andere Benutzer Änderungen am Dokument vornehmen. Außerdem wird der Status des Dokuments in Ihrem Cache auf Lesen/Schreiben geändert, damit Sie Änderungen vornehmen können. Wenn Sie ein direktes Dokument auschecken, werden auch alle darin enthaltenen indirekten Dokumente in Ihr lokales Cache ausgecheckt. Checkt ein ausgechecktes Dokument ein und macht es für andere Benutzer verfügbar.

Wenn Sie ausgecheckte Dokumente ändern, können Sie die Dokumente mit dem Befehl Alle einchecken in die verwaltete Bibliothek laden, damit sie für andere Benutzer zum Auschecken verfügbar gemacht werden. Sobald Sie Dokumente einchecken, werden diese veröffentlicht. Wenn Sie ein direktes Dokument einchecken, werden auch alle zugehörigen indirekten Dokumente eingecheckt. Sie können auch den Befehl Einchecken auf dem Kontextmenü verwenden, um ausgewählte Dokumente einzuchecken.

Verwenden Sie den Befehl Auschecken rückgängig machen auf dem Kontextmenü, wenn Sie am ausgecheckten Dokument vorgenommene Änderungen rückgängig machen wollen. Auf diese Weise wird in der verwalteten Bibliothek auch die Sperre Ausgecheckt für das Dokument aufgehoben, damit andere Benutzer das Dokument bearbeiten können. Wenn Sie das Auschecken eines direkten Dokuments rückgängig machen, wird auch das Auschecken aller zugehörigen indirekten Dokumente rückgängig gemacht. Der Befehl Auschecken rückgängig machen lädt das Dokument nicht in die Bibliothek und entfernt es nicht aus Ihrem lokalen Cache.

Dokumente in lokales Cache herunterladen

Mit der Schaltfläche Herunterladen im Dialogfeld Cache-Assistent können Sie Dokumente in der verwalteten Bibliothek auswählen und in Ihr lokales Cache herunterladen. Dies ist hilfreich, wenn Sie Ihr Cache manuell verwalten oder offline arbeiten wollen. Die Schaltfläche Herunterladen ruft das Dialogfeld Herunterladen auf, mit dessen Hilfe Sie die gewünschten Dokumente auswählen können.

Dokumente aus dem Cache löschen

Die Schaltfläche Alle löschen entfernt alle Dokumente aus Ihrem lokalen Cache. Dies ist hilfreich wenn Sie Arbeitsspeicher verfügbar machen wollen, oder die Aktualisierung des Caches mit den neuesten Daten aus der verwalteten Bibliothek erzwingen wollen.

Dokumentrevisionen prüfen

Der Befehl Revisioniert von auf dem Kontextmenü zeigt Namen und Ordnerpfad des Dokuments an, das als Vorlage zum Erstellen des ausgewählten Dokuments verwendet wurde. Der Befehl Revisionen anzeigen auf dem Kontextmenü zeigt Namen und Ordnerpfad von Dokumenten an, bei denen es sich um Revisionen des ausgewählten Dokuments handelt.

Dokumente öffnen

Der Befehl Öffnen auf dem Kontextmenü öffnet das ausgewählte Dokument in der Anwendung, mit der es erstellt wurde. Das Dokument wird geöffnet, sobald Sie das Dialogfeld Cache-Assistent schließen.


Verwalten von Solid Edge-Dokumenten

Es gibt verschiedene Methoden zum Verwalten von Solid Edge-Dokumenten. Sie können einen nichtportalen Client wie Internet Explorer verwenden, um Aufgaben wie das Kopieren oder Umbenennen von Dokumenten durchzuführen. Da diese Dokumente Informationen gemeinsam nutzen und verwenden, kann sich die Erhaltung von Beziehungsinformationen zwischen diesen Dokumenten sehr komplex gestalten. Mit der Secure Link-Technologie von Insight Connect können Sie diese Informationen verwalten. Jedes von SharePoint verwaltete Dokument verfügt über eine eindeutige ID, die Insight als Teil der Verknüpfungsinformationen speichert. Falls Insight keine Verknüpfungen in der relativen Pfadstruktur eines verwalteten Dokuments findet, wird versucht, das Dokument anhand seiner eindeutigen ID ausfindig zu machen. Sie können Dokumente mit Insight umbenennen oder verschieben, ohne den Befehl Verwendungsnachweis im Revision Manager verwenden zu müssen. Insight findet diese Dokumente automatisch. Aus diesem Grund empfehlen wir zum Verwalten von Solid Edge-Dokumenten Insight zu verwenden, um eventuelle Beziehungsprobleme vermeiden.

Hinweis: Wegen einer Einschränkung seitens Microsoft sollten Sie Insight Connect : Revision Manager verwenden, um Dokumenten zu verschieben oder umzubenennen. Wenn Sie den Internet Explorer oder den Windows Explorer zum Verschieben von Dokumenten zwischen Sites verwenden, werden die Solid Edge-Eigenschaften nicht mitverschoben.

Insight Connect verfügt über Befehle wie Umbenennen, Aus Bibliothek löschen, Unterbrochene Verknüpfungen suchen, Verknüpfungen neu definieren und Doppelte Dokumentnamen suchen, die hilfreich beim Verwalten von Dokumentverknüpfungen sind.


Benutzerdefinierte Auszüge erstellen

Sie können mit Insight benutzerdefinierte Auszüge aus Ihren Daten erstellen. Beim Erstellen dieser Auszüge werden jedoch nicht die lokalen Kopien, sondern die Eigenschafts- und Verknüpfungsdaten der in einer Bibliothek gespeicherten Dokumente verwendet. Wenn Sie also einen Auszug zu einem offenen Dokument erstellen, enthält dieser nicht die Daten des geöffneten Dokuments, sondern die der Dokumentversion, die beim letzten Einchecken des Dokuments erstellt wurde. Beim Generieren von Auszügen werden Rollenprivilegien angewendet, so dass ein Auszug je nach Rolle des Benutzers unterschiedlich ausfallen kann.

Auszugstypen

Sie können folgende Auszugstypen erstellen:

  1. Stückliste

  2. Struktur-Stückliste

  3. Mengenübersichts-Stückliste

  4. Stückliste

Formatieren von Auszügen

Mit der Option Format im Dialogfeld Auszug können Sie das Auszugsformat festlegen. Im Dialogfeld Auszugsformat können Sie folgendes einstellen:

  1. Schriftart

  2. Spaltentitel (je nach verfügbaren Eigenschaften)

  3. Sortiermethode

Für jede in den Auszug aufgenommene Eigenschaft wird eine neue Auszugsspalte erstellt. Zu den auswählbaren Standardeigenschaften gehören Menge, Dokumentnummer, Revision und Autor. Sie können außerdem selbstdefinierte Datei-Eigenschaften einbeziehen, die Sie in den Teil- und Unterbaugruppendokumenten aufgezeichnet haben.

Wenn Sie das Auszugsformat festgelegt haben, klicken Sie im Dialogfeld Auszugsformat auf die Schaltfläche OK, um eine Vorschau des Auszugs anzuzeigen.

Auszugsausgabe

Nachdem Sie die Vorschau des Auszugs überprüft haben, haben Sie folgende Möglichkeiten:

  1. den aktuellen Auszug speichern,

  2. den aktuellen Auszug drucken,

  3. den aktuellen Auszug in die Zwischenablage kopieren

  4. und einen neuen Auszug erstellen.

Speichern von Auszügen

Mit der Option Speichern unter können Sie die Ablage, den Dokumentnamen und die Ausgabeart festlegen. Auszüge können als Textdatei (TXT) oder RTF-Datei (Rich Text Format) ausgegeben werden.

Hinzufügen von Eigenschaften zu verwalteten Dokumenten

Wenn Sie verwalteten Solid Edge-Dokumenten neue benutzerdefinierte Eigenschaften hinzufügen, müssen Sie diese auch der verwalteten Dokumentbibliothek auf dem SharePoint Server hinzufügen, um sie für Baugruppenauszüge verfügbar zu machen. Verwaltete Dokumentprofile werden im Ordner Dokumentprofile auf dem SharePoint Server gespeichert. Um Solid Edge-Dateieigenschaften und verwaltete SharePoint-Dokumenteigenschaften ordnungsgemäß synchronisieren zu können, müssen diese exakt übereinstimmen.


Verwalten von Arbeitsabläufen mit Insight Server

Insight Server wird mit einer Anwendung für Insight-Arbeitsabläufe geliefert. Führen Sie die Anwendung Microsoft.SharePoint.Workflow.SetupWizard.exe im Programmordner von Insight Server aus, um die erforderlichen Listen in SharePoint zu erstellen.

Hinweis: Wenn Sie in einer Serverfarm-Umgebung arbeiten, muss diese Anwendung auf jedem Front-End-Webserver ausgeführt werden, indem Sie Insight Server auf dem Webserver installieren. Wenn Sie die Anwendung auf dem ersten Webserver ausgeführt haben, wählen Sie die vorhandenen Listen, um die Konfigurationsdatei ordnungsgemäß einzurichten.

Erste Schritte

Um mit den Arbeitsabläufen zu beginnen, müssen Sie:

  1. die Inhaltsgenehmigung aktivieren,

  2. die Ereignishandler aktivieren und

  3. den Workflow Designer einrichten.

So aktivieren Sie die Inhaltsgenehmigung

Die Anwendung für Arbeitsabläufe verwendet die Inhaltsgenehmigung, um Dokumente durch den Genehmigungsprozess zu leiten. Die Option muss eingeschaltet sein, damit der Setup-Assistent für Arbeitsabläufe eine vorhandene Dokumentbibliothek auswählen kann, falls solche bereits erstellt wurden. Wenn bereits eine Dokumentbibliothek vorhanden ist, wählen Sie auf der Seite Allgemeine Einstellungen der Dokumentbibliothek im Abschnitt Inhaltsgenehmigung die Option Ja, um die Inhaltsgenehmigung zu aktivieren.

So aktivieren Sie Ereignishandler

Die Anwendung für Arbeitsabläufe verwendet Ereignishandler, um Dokumentvorgänge zu überwachen. Gehen Sie folgendermaßen vor, um vor Ausführung des Setup-Assistenten für Arbeitsabläufe zu überprüfen, ob diese Option eingeschaltet ist.

  1. Gehen Sie zur SharePoint-Verwaltungshomepage.

  2. Wählen Sie auf dieser Seite im Abschnitt Virtuelle Serverkonfiguration die Option Virtuelle Servereinstellungen konfigurieren.

  3. Wählen Sie eine Website zum Konfigurieren aus.

  4. Wählen Sie im Abschnitt Virtuelle Serververwaltung der Seite Virtuelle Servereinstellungen die Option Allgemeine Einstellungen für virtuelle Server.

  5. Aktivieren Sie auf der Seite Allgemeine Einstellungen für virtuelle Server im Abschnitt Ereignishandler die Option Ereignishandler.

So richten Sie den Workflow Designer ein

  1. Um die Anwendung Workflow Designer verwenden zu können, müssen Sie zunächst Visio 2003 auf dem SharePoint Server installieren.

Erweiterung der Anwendung für Arbeitsabläufe

Microsoft liefert den Kern der Anwendung für Arbeitsabläufe. Insight hat die Anwendung für Arbeitsabläufe von Microsoft folgendermaßen erweitert:

  1. Eine Funktion zur Benachrichtigung des Dokumentverfassers per E-Mail, wenn das Dokument den Genehmigungsprozess vollständig durchlaufen hat oder abgelehnt wird wurde hinzugefügt.

  2. Benutzer nur für Benachrichtigungszwecke sind gestattet. Auf diese Weise kann der Arbeitsablauf Personen davon benachrichtigen, dass ein Dokument den Genehmigungsprozess durchläuft, ohne diesen Personen Genehmigungsrechte zuzuweisen.

  3. Wenn ein Dokument seinen Schwellwert erreicht, werden die verbleibenden ausstehenden Benutzer auf Genehmigen/Ablehnen gesetzt und deren Gewichtung auf 0. Auf diese Weise wird die Instanztabelle des Arbeitsablaufs bereinigt und es ist einfacher für die Benutzer zu sehen, welche Dokumente noch auf Genehmigung warten.

Konfigurieren eines Arbeitsablaufs

Es ist wichtig einige der allgemeinen Vorgänge zu verstehen, die Sie mit der Anwendung für Arbeitsabläufe durchführen können. Dieser Abschnitt behandelt lediglich einige der von Ihnen wahrscheinlich am häufigsten durchgeführten Arbeiten. Lesen jedoch unbedingt das mit Insight Server gelieferte Dokument Example Workflow with SharePoint 2003.doc, um ein besseres Verständnis der Anwendung für Arbeitsabläufe und deren Funktionen zu gewinnen.

Hinweis: Gestatten Sie beim Erstellen Ihrer Arbeitsabläufe Änderungen, indem Sie Ordinale um 10 oder 100 inkrementieren.

In den hier aufgeführten Beispielen werden Websites vorausgesetzt, die den Standardschwellwert 10 verwenden, um zu bestimmen, wann ein Dokument zum nächsten Ordinal weitergeleitet werden soll. Die aufgezeigten Beispiele können beliebig miteinander kombiniert werden, um einen Arbeitsablauf mit der erforderlichen Anzahl von Schritten für Ihre Website zu erstellen.

Serienmäßige Genehmigungen verwenden

Mit serienmäßigen Genehmigungen können Sie Dokumente in der Reihenfolge zur Genehmigung versenden, die auf dem in der Workflow Definitionstabelle festgelegten Ordinalwert basiert.

So richten Sie eine serienmäßige Genehmigung ein:

  1. Fügen Sie der Workflow Definitionstabelle für jeden Schritt im Genehmigungsprozess einen Eintrag hinzu.

  2. Weisen Sie jedem Schritt im Arbeitsablauf ein eindeutiges Ordinal mit einer Genehmigungsgewichtung von 10 zu.

Der Arbeitsablauf sendet das Dokument durch den Genehmigungszyklus und leitet es vom niedrigsten bis zum höchsten Ordinal weiter.

Das folgende Beispiel zeigt die serienmäßige Genehmigung:

  1. Design Review

  2. UI Review

Hinweis: In diesem Beispiel werden für jeden Schritt des Prozesses Approve to- und Reject to-Ordinals gezeigt. Die Anwendung genehmigt standardmäßig zum nächsthöheren Ordinal und lehnt standardmäßig auf den nächstniedrigeren Ordinal ab. Es empfiehlt sich jedoch die Felder auszufüllen, da auf diese Weise besser verständlich ist, was im Arbeitsablauf vor sich geht.

Parallele Genehmigungen verwenden

Bei parallelen Genehmigungen kann ein Ordinal mehrere Einträge enthalten, die alle genehmigt werden müssen, bevor das Dokument vollständig genehmigt ist.

Sie können einen parallelen Schritt im Arbeitsablauf erstellen, indem Sie mehrere Einträge für einen Ordinal hinzufügen. Diese Einträge können unterschiedliche Titel aufweisen, die Ordinals müssen jedoch identisch sein und die Gesamtgewichtung muss mindestens 10 oder mehr betragen. Das folgende Beispiel zeigt die parallele Genehmigung:

  1. Design Review

  2. UI Review

Beide Einträge müssen genehmigt werden, bevor ein Dokument vollständig genehmigt werden kann.

Mit parallelen Genehmigungen können Sie im Arbeitsablauf Schritte einfügen, die die Genehmigung durch die Mehrheit erfordern, bevor das Dokument zum nächsten Ordinal weitergeleitet wird. Es ist hierbei wichtig jedem Benutzer eine ausreichende Genehmigungsgewichtung zuzuweisen, damit bei Erreichen einer Gewichtung von 10 oder mehr die erforderliche Anzahl von Genehmigungen vorliegt. In folgenden Beispiel erfordert das Dokument die Genehmigung einer von drei Personen: Axel, Werner oder Markus.

Sie können die Genehmigungsgewichtung für jeden Benutzer auf 5 verringern, um festzulegen, dass zwei von drei Personen das Dokument genehmigen müssen.

Parallele Schritte können auch einen “Master”-Bevollmächtigten enthalten, der die Entscheidung aller anderen überstimmen kann. Zu diesem Zweck können Sie einer Person im Ordinal eine Genehmigungsgewichtung von 10 zuweisen. Dies ist hilfreich, wenn keine Einstimmigkeit erzielt werden kann oder wenn zu viele Personen abwesend sind. Im folgenden Beispiel kann Berthold ein Dokument unabhängig von den anderen Benutzern genehmigen oder ablehnen:

Fügen Sie einen Person mit einer Genehmigungsgewichtung von 0 hinzu, um einen Benutzer anzugeben, der nur benachrichtigt werden soll. Im folgenden Beispiel wurde Markus als Benutzer nur für Benachrichtigungszwecke hinzugefügt:

Benutzerbasierter Abzweig

Bei der parallelen Genehmigung kann es vorkommen, dass der das Dokument genehmigende Benutzer den Genehmigungsprozess abzweigt. Weisen Sie hierzu jedem Benutzer eine ausreichende Gewichtung zur Genehmigung des Dokuments zum nächsten Ordinal zu und jedem Benutzer verschiedene Approve To-Ordinals.

Hinweis: In diesem Beispiel werden für jeden Schritt des Prozesses Approve to- und Reject to-Ordinals gezeigt. Die Anwendung genehmigt standardmäßig zum nächsthöheren Ordinal und lehnt standardmäßig auf den nächstniedrigeren Ordinal ab. Es empfiehlt sich jedoch die Felder auszufüllen, da auf diese Weise besser verständlich ist, was im Arbeitsablauf vor sich geht.

Alle Abzweige müssen an einem gemeinsamen endgültigen Ordinal enden, da die Anwendung automatisch zum nächsthöheren Ordinal inkrementiert, sobald die Genehmigungen in jedem Schritt vollständig sind. Wenn in diesem Beispiel der Zweig 100 keine endgültige Genehmigung aufweist, die den Prozess zu Ordinal 900 weiterleitet, wird Zweig 200 gestartet und anschließend Zweig 300.

Weitere Informationen zu Arbeitsabläufen

Dokument werden im Arbeitsablauf vorwärts geleitet, wenn die Summe der Genehmigungsgewichtung größer als der Gewichtungsschwellwert (Standardwert 10) ist oder ihm entspricht.

Wenn ein Benutzer ein Dokument ablehnt, wird dessen Genehmigungsgewichtung als negativer Wert addiert. Wenn die Summe der Genehmigungsgewichtung gleich oder kleiner als -10 ist, wird das Dokument zum vorherigen Ordinal abgelehnt.

Bei parallelen Schritten ist es möglich, dass einige Benutzer das Dokument genehmigen (positive Genehmigungsgewichtung) und andere Benutzer das Dokument ablehnen (negative Genehmigungsgewichtung), so dass die Gesamtgewichtung niemals +/- 10 erreicht. Es gibt mehrere Möglichkeiten solchen Problemen vorzubeugen. Stellen Sie sicher, dass Sie für parallele Ordinals immer ein Fälligkeitsdatum festlegen. Wird ein Dokument bis zu diesem Datum weder genehmigt noch abgelehnt, dann wird es automatisch abgelehnt. Sie können auch einen Master-Bevollmächtigten zuweisen, der die Entscheidung aller anderen überstimmen kann.

Die Workflow Definitionsliste wird standardmäßig in Reihenfolge der in dieser Liste vorgenommenen Einträge sortiert. Sie können den Genehmigungsprozess übersichtlicher gestalten, indem Sie die standardmäßige Sortierung der Liste ändern und hierzu die Standardansicht modifizieren. Sie können die Liste beispielsweise nach Dokumentbibliotheksspalten gruppieren und anhand dem Ordinal in absteigender Reihenfolge sortieren.

Wenn Sie mehrere umfangreiche Arbeitsabläufe haben, können Sie für jede Bibliothek eine separate Ansicht erstellen. Erstellen Sie eine neue öffentliche oder persönliche Ansicht. Sortieren Sie die Ansicht aufgrund der Spalte Ordinal und filtern Sie die Ansicht nach Dokumentbibliotheken.

Das Hinzufügen der neuen Ansicht fügt dem Abschnitt Wählen Sie eine Ansicht auf der linken Kontextleiste der Seite Workflow Definitions- einen neuen Eintrag hinzu.

Obwohl oftmals unterschiedlich bezeichnet, erfüllen Technische Änderungsaufträge (ECO), Technische Änderungsmitteilungen (ECN) oder Technische Änderungsanforderungen alle den selben Sinn und Zweck. Es handelt sich um ein Informationspaket, das technische Änderungen innerhalb des Entwicklungs-- und Fertigungsprozesses verfolgt.

Technische Änderungen bestehen gewöhnlich aus einer Reihe von Änderungsanforderungen, die an die Zeichnung angehängt sind. Sie verfügen über eine Identifikationsnummer, eine Änderungsanforderung einschließlich dem Namen der Person, die die Änderung erfordert, sowie dem Zeitpunkt der Anforderung und einem Verteiler, der die Personen identifiziert, die diese Änderung genehmigen müssen. Sobald eine Änderung genehmigt wird, wird der technischen Änderung ein Gültigkeitsdatum hinzugefügt, um anzuzeigen, ab wann die Änderung in der Fertigung verwendet werden soll. Am Gültigkeitsdatum werden die genehmigten Zeichnungen an einem Ort abgelegt, an dem Personen der Fertigungsabteilung Einsicht nehmen können.

In einer elektronischen Umgebung durchläuft ein die Änderungen beschreibendes Dokument bzw. Dokumentsatz verschiedene Genehmigungsvati anhand der Schritte im Arbeitsablauf.

Implementierung eines technischen Änderungsprozesses mit der Kollaborationsdatei (PCF)

Zum Implementieren von Insight und der Kollaborationsdatei müssen Sie einige Schritte durchführen.

  1. Stellen Sie sicher, dass den angegebenen Websitegruppen für jede Dokumentbibliothek Benutzer zugeordnet sind.

  2. Überprüfen Sie, ob die Berechtigungen eines jeden Benutzers für jede Dokumentbibliothek ordnungsgemäß funktionieren.

  3. Führen Sie Solid Edge Administrator aus, um die Standardstammordner einzurichten.

  4. Richten Sie für die entsprechenden Benutzer in der Kollaborations-Dokumentbibliothek Warnmeldungen ein.

  5. Stellen Sie in den ECR- und ECO-Dokumentbibliotheken Approvals/Moderation auf ON.

Die PCF-Dokumentbibliotheksablage ist ein Ort innerhalb auf Website für Ingenieure auf die anderes Personal wie z.B. Mitarbeiter aus der Fertigung Schreibzugriff haben. Hier können solche Mitarbeiter PCF-Dateien erstellen und in der Ablage "Eingang" speichern.

Durch Änderungen an den ECR- und ECO-Dokumentbibliotheken kann ein Genehmigungsarbeitsablauf gestartet werden, sobald eine PCF-Datei an diesem Ort abgelegt wird.

Die ECR-Dokumentbibliothek kann als der Ort verstanden werden, an dem die Genehmigung für die Erstellung von Revisionen freigegebener Dokumente angefordert werden kann. Wenn Ihr Unternehmen keine Genehmigung zum Erstellen revidierter Dokumente erfordert, können Sie diese Dokumentbibliothek überspringen und Revisionen ohne Genehmigung erstellen.

Die ECO-Dokumentbibliothek kann als der Ort verstanden werden, an dem die Freigabe von revidierten Dokumente nach Beendung aller Revisionen angefordert werden kann.

Beispiel für Implementierung einer technischen Änderung mit Insight

Die folgenden Arbeitsschritte beschreiben den Arbeitsablauf zum Verwenden von Insight Connect : View and Markup zur Implementierung eines technischen Änderungsauftrags. In diesem Beispiel durchläuft Assembly1.asm den ECO-Arbeitsablauf. Dieses Beispiel geht davon aus, dass alle Schritte zur Erstellung den ECO-Arbeitsablaufs ausgeführt wurden und die in der Tabelle aufgeführten Benutzer, Rollen und Dokumentbibliotheken entsprechend eingerichtet wurden.

Benutzer | PreRelease Subsite | Release Subsite | Obsolete Subsite | Markup Subsite | ECO Subsite | ECR Subsite
Fertigungsabteilung TechSupport | Keine | Leser | Keine | Ersteller | Leser | Leser
Ingenieur | Ersteller | Leser | Leser | Ersteller | Ersteller | Ersteller
Freigabe-Manager | Löschberechtigter | Löschberechtigter | Löschberechtigter | Löschberechtigter | Löschberechtigter | Löschberechtigter
Administrator | Alle | Alle | Alle | Alle | Alle | Alle
SESTATUS | Verfügbar In Arbeit Wird geprüft | Freigegeben Festgeschrieben | Ungültig | Verfügbar | Verfügbar In Arbeit Wird geprüft | Verfügbar In Arbeit Wird geprüft

Hinweis: Der Benutzer, der die Kollaborationsdatei von einem Ort zum nächste leitet, muss über die Berechtigung zum Löschen verfügen. Sie wollen Ihren Arbeitsablauf wahrscheinlich so einrichten, dass die PCF-Datei von einem Manager oder Administrator weitergeleitet werden kann, jedoch nicht von einem Ingenieur oder einem Mitarbeiter aus der Fertigung.

Aufbau des Arbeitsablaufs

  1. Ein Mitarbeiter aus der Fertigungsabteilung stellt ein Problem in einer Baugruppe fest und sucht auf der Website Released nach dem Assembly-Dokument oder dem zugehörigen Draft-Dokument.

Hinweis: Er kann auch suchen, ob bereits PCF-Dokumente für das Assembly-Dokument oder Draft-Dokument vorhanden sind.

  2. Der Mitarbeiter aus der Fertigung öffnet Assembly1.asm in Insight Connect : View and Markup und schaut sich die Baugruppe an. Er fügt dem Assembly-Dokument Bemerkungen hinzu und speichert deren Inhalt als PCF-Datei.

  3. Wenn die Datei der PCF-Dokumentbibliothek hinzugefügt wird, erhält ein Ingenieur eine Benachrichtigung per E-Mail. Die Benachrichtigung per E-Mail erfolgt nur dann, wenn für diese Bibliothek Warnmeldungen aktiviert sind.

  4. Der Ingenieur öffnet die Kollaborationsdatei und überprüft die Bemerkungen des Fertigungsmitarbeiters, die darauf hinweisen, dass Part3.par überarbeitet werden muss.

  5. Der Ingenieur wechselt, ohne Insight Connect zu verlassen, von View and Markup zum Revision Manager und führt eine Verwendungsnachweissuche aus, um festzustellen welche Dokumente von dieser Revision betroffen werden. Das Suchergebnis lautet:

  6. Part3.par, Part3.dft

  7. S2.asm, S2.dft

  8. AssemblyA.asm, AssemblyA.dft

  9. AssemblyC.asm, AssemblyC.dft

  6. Der Ingenieur kann die angegebenen Aktionen durchführen, wenn keine Genehmigung erforderlich ist, oder aber der PCF-Datei Informationen hinzufügen, die die angeforderten Revisionen beschreiben. Hierzu kann er ein Office-Dokument verwenden.

  7. Der Ingenieur fügt alle zur Beschreibung der angeforderten Änderung erforderlichen Informationen hinzu und speichert die PCF-Datei.

  8. Der Freigabe-Manager verschiebt die fertig gestellte Kollaborationsdatei je nach der angeforderten Genehmigung in die ECR- oder ECO- Ablage. Für diese Ablagen muss Moderations aktiviert sein. Die Genehmigungsbevollmächtigten für die ECR-Ablage erhalten eine Benachrichtigung zur Genehmigung der Kollaborationsdatei.

  9. Die Genehmigungsbevollmächtigten überprüfen die PCF-Datei in der ECR-Dokumentbibliothek und genehmigen die angeforderten Änderungen oder lehnen sie ab. Beachten Sie, dass die Genehmigungsbevollmächtigten für ECR (technische Änderungsanforderung) zu diesem Zeitpunkt die Anforderung zur Erstellung von Revisionen für freigegebene Dokumente genehmigen oder ablehnen.

  10. Sobald die Anforderung zum Erstellen von Revisionen genehmigt wurde, kann der Ingenieur die selbe Kollaborationsdatei öffnen, Revision Manager aufrufen und den Befehl Aktionen durchführen ausführen. Die revidierten Dokumente werden automatisch im Stammorder der Dokumentbibliothek Pre-Release erstellt und deren Status auf verfügbar gesetzt.

    Solid Edge ist fähig alle erforderlichen Änderungen durchzuführen, die in der Kollaborationsdatei dokumentiert sind.

  11. Wenn alle revidierten Dokumente vollständig sind, öffnet der Ingenieur die Kollaborationsdatei und aktualisiert sie mit den Informationen, dass alle Änderungen durchgeführt wurden.

  12. Der Freigabe-Manager verschiebt die Kollaborationsdatei von der ECR-Dokumentbibliothek in die ECO-Dokumentbibliothek, wobei Moderation aktiviert ist. Er wendet zur gleichen Zeit den Lebenszyklusassistent auf die Kollaborationsdatei an, um den Status aller revidierten Dokumente auf Wird überprüft zu setzen.

  13. Die Genehmigungsbevollmächtigten für die ECO-Dokumentbibliothek genehmigen die Anforderung zur Freigabe der revidierten Dokumente oder lehnen sie ab.

  14. Nach erfolgter Genehmigung wird der Freigabe-Manager benachrichtigt dass der technische Änderungsauftrag (ECO) genehmigt wurde.

  15. Der Freigabe-Manager verwendet den Lebenszyklusassistenten, um alle revidierten Dokumente in den Ordner Released zu verschieben. Hierzu geht er folgendermaßen vor:

  1. Er öffnet die Kollaborationsdatei, um eine Liste der revidierten Dokumente im Lebenszyklusassistenten abzurufen.

  2. Er verschiebt die Dokumente in die Dokumentbibliothek Released und ändert den Status auf Freigegeben.

    Wenn die Option zum ungültig machen von alten Dateien aktiv ist , verschiebt er die ursprünglichen Dateien in die Dokumentbibliothek Obsolete und ändert den Status auf Ungültig.

  16. Der Freigabe-Manager verschiebt die Kollaborationsdatei in den Ordner für technische Änderungsmitteilungen (ECN). Auf diese Weise werden alle Beteiligten, die über Warnmeldungen verfügen benachrichtigt, dass das neue freigegebene Produkt für die Fertigung zur Verfügung steht.


Typischer Arbeitsablauf zum Verwalten von Solid Edge-Dokumenten in SharePoint

Typischer Arbeitsablauf zum Verwenden der Insight-Technologie zum Verwalten von Solid Edge-Dokumenten in einer Bibliothek

Mit der im Lieferumfang von Solid Edge enthaltenen Insight-Technologie können Sie einfach mit Ihren Solid Edge-Dokumenten in einer verwalteten Bibliothek arbeiten.

Befolgen Sie bei der Arbeit mit Solid Edge-Dokumenten folgenden typischen Arbeitsablauf:

  1. Erstellen Sie ein Solide Edge-Dokument und verwenden Sie den Befehl Speichern unter, um das Dokument in einer SharePoint-Bibliothek zu speichern.

            2.

    Hinweis: Das Dokument wird noch nicht in der Bibliothek gespeichert; es wird vorerst in Ihrem Cache gespeichert.

  2. Schließen Sie das Dokument, um es zu übertragen und zur Bibliothek hinzuzufügen.

  3. Öffnen Sie das Dokument, um es auszuchecken.

Insight veröfftentlicht das Dokument bei jedem Einchecken und stellt sicher, dass in SharePoint alle Genehmigungen für den Ordner ausgeschaltet sind.

Hinweis: Bei einem typischen Microsoft SharePoint-Arbeitsablauf werden Dokumentgenehmigungen angefordert und Dokumente veröffentlicht, so dass diese von anderen Benutzern angezeigt werden können. Solid Edge verfügt jedoch über einen eigenen Arbeitsablauf der SharePoint-Genehmigungen nicht verwendet.


Protokolldateien in Solid Edge anzeigen

Alle Insight-Warnungen und Fehlermeldungen werden in einem allgemeinen Dialogfeld für Fehlermeldungen angezeigt und in die Protokolldatei geschrieben. Das Dialogfeld zeigt Fehler und Warnungen für den letzten Befehl an. Sie können eine Spalte im Dialogfeld auswählen, um die Informationen in diesem Dialogfeld basierend auf der ausgewählten Spalte zu sortieren.

Das System erstellt für jede Sitzung eine Protokolldatei im ASCII-Textformat, die die Warnungen und Fehlermeldungen für die gesamte Sitzung enthält. Sie können diese Datei in Word, Excel oder einer anderen Anwendung öffnen, die durch Tabstopps getrennte Textdateien lesen kann. Das System benennt die Protokolldatei basierend auf dem Zeitstempel der Datei.

Die Protokolldatei wird in dem Ordner gespeichert, der auf der Registerkarte Dateiablage im Dialogfeld Optionen definiert wurde. Sie können Insight auch anweisen, nach der Datei in einem anderen Ordner oder einem Ordner auf einem anderen Computer innerhalb eines Netzwerks zu suchen. Klicken Sie zum Festlegen einer anderen Ablage im Menü Extras auf Optionen. Wählen Sie Protokolldateien auf der Registerkarte Dateiablage des Dialogfeldes Optionen, und klicken Sie auf Ändern. Im Dialogfeld Durchsuchen können Sie den Ordner angeben, der die Protokolldatei enthält.

Fehlermeldungen in Insight

Die folgenden Informationen beschreiben die verschiedenen Insight-Fehlermeldungen:

Verbindungsaufnahme mit dem Server fehlgeschlagen, versuchen Sie es erneut. Wenden Sie sich an Ihren Administrator, falls das Problem anhält.

Dieser Fehler tritt auf, wenn es ein Problem bei der Server-Verbindung gibt. Das Netzwerk funktioniert möglicherweise nicht oder der Server ist nicht verfügbar. Falls dieser Fehler während der Ausführung des Befehls auftritt, wird das Dokument möglicherweise in SharePoint als Ausgecheckt markiert, ohne auf Ihre lokale Maschine geladen zu sein. In diesem Fall muss ein Administrator die Datei bereinigen oder das Auschecken abbrechen, um die Bibliothek zu aktualisieren.

Nicht genügend Speicherplatz für <Datei>. Bitten Sie Ihren Administrator ausreichenden Speicherplatz freizustellen und versuchen Sie es erneut.

Dieser Fehler tritt auf, wenn der Server oder die lokale Maschine nicht über ausreichend Speicherplatz für das Dokument verfügen. Ein Administrator muss das Cache leeren, Dateien vom System entfernen oder Dokumentversionen bereinigen, um den Fehler zu beheben. Sie müssen möglicherweise eine größere Festplatte installieren, falls dieses Problem häufig auftritt.

<Ordner> hat aktivierte Genehmigungen. Deaktivieren Sie Genehmigungen und führen Sie den Befehl erneut aus.

Dieser Fehler tritt auf, wenn ein Administrator SharePoint-Genehmigungen aktiviert hat. Der Administrator muss die Genehmigungen deaktivieren, um das Problem zu beheben.

Sie haben keine ausreichende Berechtigung für <Befehl> <Dateiname oder Ordnername> oder es liegen Netzwerkprobleme vor, die die Echtheitsbestätigung vom Server verhindern.

Dieser Fehler tritt auf, wenn Sie nicht über ausreichend Berechtigungen verfügen, um einen Befehl auszuführen. Ein Administrator kann Ihnen die erforderlichen Berechtigungen für einen Befehl erteilen, um den Fehler zu beheben. Außerdem kann ein anderer Benutzer, der über eine ausreichende Berechtigung verfügt, den Befehl ausführen.

Die Datei ist bereits in <Ordnername> vorhanden. Benennen Sie eines der Dokumente oder das doppelte Dokument neu.

Dieser Fehler tritt auf, wenn ein Dokument mit dem selben Namen bereits in SharePoint vorhanden ist. Entfernen Sie das vorhandene Dokument aus dem Cache oder ignorieren Sie diese Meldung und fahren Sie fort, um den Fehler zu beheben.

<Alter Ordnername> kann nicht umbenannt werden. Es ist bereits ein Ordner mit dem angegebenen Namen vorhanden. Geben Sie einen anderen Ordnernamen an.

Dieser Fehler tritt auf, wenn ein Ordner mit dem selben Namen bereits in SharePoint vorhanden ist. Stellen Sie den ursprünglichen Ordnernamen wieder her und wählen Sie einen anderen Ordnernamen, um den Fehler zu beheben.

Datei ist gesperrt. Schließen Sie sie in Solid Edge oder der Anwendung, in der sie verwendet wird.

Dieser Fehler tritt auf, wenn ein Dokument vom System gesperrt wird, da es in Solid Edge oder einer anderen Anwendung geöffnet ist. Schließen Sie das Dokument in Solid Edge oder der Anwendung, die die Sperre verursacht, um den Fehler zu beheben.

Datei <Dateiname> wurde von <Benutzer> ausgecheckt. Öffnen Sie die Datei schreibgeschützt.

Dieser Fehler tritt auf, wenn ein Dokument von einem anderen Benutzer ausgecheckt wurde. Der Benutzer muss das Dokument einchecken, bevor es von einem anderen Benutzer ausgecheckt werden kann, um den Fehler zu beheben.


Insight mit anderen Systemen integrieren

Dieses Dokument beschreibt, wie Sie Solid Edge Insight-Verknüpfungsinformationen aus SharePoint extrahieren können, um es mit einem Engineering Resource Planning (ERP)- oder Manufacturing Resource Planning (MRP)-System zu integrieren.

Sie können das Windows SharePoint Services/Portal Server Software Development Kit verwenden, um SharePoint mit anderen Systemen zu integrieren.

Das Windows SharePoint Services/SharePoint Portal Server Software Development Kit

Mit dem Windows SharePoint Services/SharePoint Portal Server Development Kit (SDK) von Microsoft können Sie Anwendungen entwickeln, die mit SharePoint Portal Server verbunden werden können. Das Hilfedokument für das SharePoint SDK enthält die folgenden Abschnitte:

  1. Konzepte und Architektur - Dieser Abschnitt beschreibt die Komponenten von SharePoint Portal Server.

  2. Szenarien - Dieser Abschnitt enthält konzeptuelle Informationen und Verfahren zum Erweitern von SharePoint Portal Server.

  3. Referenz - Dieser Abschnitt enthält Referenzmaterial für Objekte, Suchsprache, Methoden und Eigenschaften und andere Komponenten, die von Anwendungen für den Zugriff auf SharePoint Portal Server verwendet werden.

  4. Beispiele - Dieser Abschnitt enthält Codebeispiele.

  5. SharePoint Portal Server-Codeverfahren - Dieser Abschnitt enthält Informationen über Codeverfahren für SharePoint Portal Server-Anwendungen.

Solid Edge-Eigenschaften

Die folgende Tabelle beschreibt die Informationen, die in den SharePoint-Metadaten als Teil der SELinkData gespeichert werden:

Nummer | Eigenschaft | Datentyp | Beschreibung
1 | SELinks | Zeichenfolge | URL für das verknüpfte Dokument.
2 | SEGUID | Zeichenfolge | Eine eindeutige ID für jedes Dokument der SharePoint-Site oder Dokumentbibliothek.
3 | SELinkName | Zeichenfolge | Vorkommnisname (ist der "Dokumentname:#", sofern er nicht geändert wurde).
4 | SELinkID | ULONG | Vorkommnis-ID.
5 | SEQuantity | ULONG | Menge
6 | SEIncludeInBOM | Boole'sch | Dieses Dokument in einem Datenauszug einbeziehen.
7 | SEDisplayInDrawings | Boole'sch | Dieses Dokument anzeigen, falls es sich in einer Zeichnung befindet.
8 | SEDisplayWhenSub | Boole'sch | Dieses Dokument anzeigen, falls es sich in einer Unterbaugruppe befindet.
9 | SELinkType | ULONG | Verknüpfungstyp.

Die ersten fünf Eigenschaften werden in einer einzelnen Zeichenfolge hinzugefügt, die durch ">" getrennt ist. Die verbleibenden vier Eigenschaften (6-9) werden in einer einzelnen ULONG-Variable zusammengefasst und als Bits hinzugefügt.

Die Informationen jeder Verknüpfung werden im folgenden Format gespeichert:

SELink Path > SEGUID > SELinkName > SELinkID > SEQuantity > SE - Verbleibende Eigenschaften (in rot dargestellt).

Eigenschaften in einem einzelnen Wert zusammenfassen

Die folgenden Konstanten werden zum Zusammenfassen der vier Eigenschaften (SEDisplayInDrawings, SEDisplayWhenSub, SEIncludeInBOM und SELinkType) in einen einzelnen ULONG-Wert verwendet.

SEDisplayWhenSub, SEIncludeInBOM und SEDisplayInDrawings sind Boole'sche Typen. Das Bit wird hinzugefügt, wenn der Wert der Eigenschaft wahr ist. Die Werte der Bits der drei Eigenschaften ist unten aufgeführt.

#define SELinkProps_IncludeInBOM 0x01
#define SELinkProps_DisplayInDrawings 0x02
#define SELinkProps_DisplayWhenSub 0x04

Es gibt vier verschiedene Typen von Verknüpfungen in Solid Edge, die von Insight erfasst werden. Wenn die Verknüpfungen keinem dieser vier Typen zugeordnet werden können, dann wird der Verknüpfungstyp als unbekannt festgelegt.

#define SELinkProps_LinkTypeUnknown 0x00
#define SELinkProps_LinkTypeComponent 0x10
#define SELinkProps_LinkTypeInterPart 0x20
#define SELinkProps_LinkTypeReverse 0x40
#define SELinkProps_LinkTypeForeign 0x80

Bei Verknüpfungen mit

SEIncludeInBOM as TRUE
SEDisplayInDrawings as FALSE
SEDisplayWhenSub as TRUE
SELinkType als Typkomponente

Werden Daten durch Hinzufügen aller erforderlicher Bits SELinkProps_IncludeInBOM | SELinkProps_DisplayWhenSub | SELinkProps_DisplayWhenSub zusammengefasst und als einzelne ULONG-Daten erstellt. Da der Wert von SEDisplayInDrawings Falsch ist, wird er nicht hinzugefügt.

SELinkData-Beispiel

Stellen Sie sich in dem folgenden Beispiel vor, dass Sie die Datei 3blocks.asm importieren, die Verknüpfungen mit den Dateien block1.par, block2.par und block3.par enthält. Alle vier Dateien werden zum selben Ordner http://servername/<document library>name/documents/assemblies/ hinzugefügt.

Die Verknüpfungseigenschaften von block1.par sind:

SELink | http://servername/<document library>name/documents/assemblies/block1.par
SEGUID | {14557CA9-0AC6-4C2A-BCD3-149C5279AE1C}
SELinkName | block1.par:1
SEQuantity | 1
SELinkID | 128
SEIncludeInBOM | WAHR
SEDisplayInDrawings | FALSCH
SEDisplayWhenSub | WAHR
SELinkType | Typenkomponente

Nehmen Sie an, dass Sie beim Zusammenfassen der letzten vier Eigenschaften den Wert "X" erhalten.

In der Zeichenfolge LinkInfo werden die zwei Eigenschaftswerte durch ein “>” getrennt. Das Format der Zeichenfolge LinkInfo ist SELink Path > SEGUID > SELinkName > SELinkID > SEQuantity > SE - Verbleibende Eigenschaften.

Die vollständige Zeichenfolge für Block1.par sieht wie folgt aus:

http://servername/<document library>name/documents/assemblies/block1.par > {14557CA9-0AC6-4C2A-BCD3-149C5279AE1C} > block1.par:1 > 128 > 1 > X

So können auch die Zeichenfolgen für block2.par und block3.par wie folgt aussehen:

http://servername/<document library>name/documents/assemblies/block2.par > {25297CA9-0AC6-4C2A-BCD3-149C5254SDS4} > block2.par:1 > 142 > 1 > X

http://servername/<document library>name/documents/assemblies/block3.par > {454DFA9-0AC6-4C2A-BCD3-149C527HJ45} > block3.par:1 > 176 > 1 > X

Wie bereits vorher erwähnt werden drei Zeichenfolgen in einem einzelnen Platz in den Metadaten zusammengefügt und durch ein "|" getrennt. Deshalb sieht die letzte Zeichenfolge, die in den Platz von SELinkData geschrieben wird, wie folgt aus:

“http://servername/<document library>name/documents/assemblies/block1.par > {14557CA9-0AC6-4C2A-BCD3-149C5279AE1C} > block1.par:1 > 128 > 1 > X | http://servername/<document library>name/documents/assemblies/block2.par > {25297CA9-0AC6-4C2A-BCD3-149C5254SDS4} > block2.par:1 > 142 > 1 > X | http://servername/<document library>name/documents/assemblies/block3.par > {454DFA9-0AC6-4C2A-BCD3-149C527HJ45} > block3.par:1 > 176 > 1 > X”

Versionsstempel

Die Solid Edge-Version wird als erster und letzter Eintrag in SELinkData hinzugefügt, um anzuzeigen, dass die Dokumente entweder mit dem Solid Edge-Befehl Speichern unter oder Zur Bibliothek hinzufügen hinzugefügt wurden. Durch den Versionsstempel kann Solid Edge zwischen Dokumenten, dessen aktualisierte Verknüpfungen auf Cache-Ablagen verweisen und Dokumenten, die ohne Solid Edge in SharePoint abgelegt wurden, unterscheiden. Außerdem identifiziert der Versionsstempel die Solid Edge-Version, die zum Hinzufügen des Dokuments in SharePoint verwendet wurde.

Der endgültige Wert der Zeichenfolge sieht wie folgt aus:

Solid Edge Version xx.xx.xx.xx
http://servername/<document library>name/documents/assemblies/block1.par > {14557CA9-0AC6-4C2A-BCD3-149C5279AE1C} > block1.par:1 > 128 > 1 > X | http://servername/<document library>name/documents/assemblies/block2.par > {25297CA9-0AC6-4C2A-BCD3-149C5254SDS4} > block2.par:1 > 142 > 1 > X | http://servername/<document library>name/documents/assemblies/block3.par > {454DFA9-0AC6-4C2A-BCD3-149C527HJ45} > block3.par:1 > 176 > 1 > X
Solid Edge version xx.xx.xx.xx

Erstellen der Anwendung

Es gibt eine Reihe von Schritten, die beim Erstellen der Anwendung erforderlich sind:

  1. Verbindung zur SharePoint-Dokumentbibliothek herstellen

  2. Abfrage für ein bestimmtes Dokument erstellen

  3. Verknüpfungsinformationen für das Dokument abrufen

  4. Entscheiden, welche Verknüpfungen in die Stückliste einbezogen werden sollen

  5. Informationen über die verknüpften Dokumente abrufen


Offline mit Insight arbeiten

Ihr Arbeitsablauf erfordert es möglicherweise, dass Sie manchmal Offline arbeiten müssen. Sie müssen möglicherweise einen Laptop-Computer aus dem Büro zu einem Kunden mitnehmen. Das Microsoft Loopback-Adapter ist eine Funktion, die Ihnen das Arbeiten in einem virtuellen Netzwerk ohne physischen Netzwerkzugriff ermöglicht. Wenn Sie das Loopback-Adapter aktivieren, wird die Leistung beim Offline-Arbeiten mit Solid Edge Insight verbessert.

So installieren Sie das Microsoft Loopback-Adapter

  1. Wählen Sie nacheinander Start > Einstellungen > Systemsteuerung.

  2. Doppelklicken Sie unter Systemsteuerung auf Hardware.

  3. Klicken Sie auf Weiter.

  4. Wählen Sie die Option Gerät hinzufügen bzw. Problem beheben und klicken Sie anschließend auf Weiter.

  5. Wählen Sie Neues Gerät hinzufügen und klicken Sie anschließend auf Weiter.

  6. Wählen Sie Nein, die Hardwarekomponenten selbst in der Liste auswählen und klicken Sie anschließend auf Weiter.

  7. Wählen Sie Netzwerkadapter und klicken Sie auf Weiter.

  8. Wählen Sie Microsoft unter Hersteller.

  9. Wählen Sie Microsoft Loopbackadapter unter Netzwerkadapter und klicken Sie auf Weiter.

  10. Klicken Sie im Dialogfeld Hardwareinstallation starten auf Weiter.

  11. Klicken Sie auf Fertig stellen.

So konfigurieren Sie das Microsoft Loopbackadapter

Nach der Installation des Microsoft Loopbackadapters müssen Sie es konfigurieren.

  1. Wählen Sie Start > Einstellungen > Netzwerk- und DFÜ-Verbindungen.

  2. Klicken Sie im Dialogfeld Netzwerk- und DFÜ-Verbindungen über dem letzten Eintrag LAN-Verbindung auf die rechte Maustaste und benennen Sie diesen Eintrag in MS Loopbackadapter um.

  3. Klicken Sie mit der rechten Maustaste auf MS Loopbackadapter und wählen Sie Eigenschaften im Kontextmenü.

  4. Stellen Sie auf der Registerkarte Allgemein im Dialogfeld Eigenschaften von MS Loopbackadapter sicher, dass als einzige Option NetBEUI-Protokoll gewählt ist.

  5. Klicken Sie auf die Schaltfläche OK.

  6. Deaktivieren Sie zuerst den Eintrag für die LAN-Verbindung im Dialogfeld Netzwerk- und DFÜ-Verbindungen, bevor Sie die Option Microsoft Loopbackadapter aktivieren, um Netzwerkkonflikte zu vermeiden. Wählen Sie den Eintrag LAN-Verbindung und klicken Sie auf die rechte Maustaste. Wählen Sie anschließend im Kontextmenü Deaktivieren.

  7. Wählen Sie den Eintrag MS Loopbackadapter im Dialogfeld Netzwerk- und DFÜ-Verbindungen und klicken Sie auf die rechte Maustaste. Wählen Sie anschließend im Kontextmenü Aktivieren, damit der Adapter funktioniert. Viele Systeme haben dieses Adapter bereits aktiviert und zeigen Ihnen nur die Option Deaktivieren an. Gehen Sie in diesem Fall zum nächsten Schritt weiter.

  8. Deaktivieren Sie zuerst den Microsoft Loopbackadapter und aktivieren Sie anschließend die LAN-Verbindung, um die LAN-Verbindung wieder herzustellen.


Überprüfen des Setups

Um die ordnungsgemäße Funktion Ihres Systems sicherzustellen, müssen mehrere Komponenten installiert sein. Falls Probleme auftreten müssen Sie diese Komponenten überprüfen.

Überprüfen Sie ob SQL Server 2000 SP3 installiert ist

  1. Melden Sie sich auf dem Server mit dem Konto an, das Sie zum Installieren des SQL Servers verwendet haben.

  2. Überprüfen Sie, ob SQL Server 2000 SP3 oder eine neuere Version installiert ist. Für die englische Version von SQL Server 2000 SP3: Wählen Sie im Dialogfeld zum Hinzufügen bzw. Entfernen von Programmen den Eintrag SQL Server und klicken Sie auf Supportinformationen. Die angezeigte Versionsnummer sollte 8.00.761 lauten.

  3. Außerdem sollte sich eine SP3areadme.htm-Datei im Verzeichnis $:\Programme\Microsoft SQL Server\MSSQL befinden. Der Dateiname hängt von dem installierten Servicepack ab.

Überprüfen Sie ob SQL Service Manager läuft

  1. Klicken Sie mit der rechten Maustaste auf das SQL Service Manager-Symbol auf dem Desktop und klicken Sie anschließend auf SQL Service Manager öffnen.

Der aktuelle Server sollte im der Server-Steuerelement angezeigt werden.

Das Listenfeld Dienste sollte fünf Dienste enthalten:

  1. Distributed Transaction Coordinator

  2. Microsoft Search

  3. MSSQL ServerOLAPService

  4. SQL Server

  5. SQL Server-Agent

  2. Wählen Sie die einzelnen Dienste aus und überprüfen Sie, ob diese ausgeführt werden und auf Dienst bei Betriebssystemstart automatisch starten eingestellt sind.

Hinweis: Nicht alle Dienste müssen ausgeführt werde. Es müssen jedoch mindestens die Dienste Microsoft Search und SQL Server laufen und es können je nach Ihrer Konfiguration andere Dienste erforderlich sein.

  3. Verlassen Sie die Anwendung SQL Service Manager.

Überprüfen Sie ob die SharePoint Inhalts- und Informationsdatenbanken erstellt wurden

  1. Rufen Sie über das Startmenü den SQL Enterprise Manager auf.

  2. Blättern Sie abwärts bis zum Knoten Datenbanken und suchen Sie nach zwei Datenbanken.

  3. Der Name der Standardkonfigurationsdatenbank lautet configdb.

  4. Der Name der SharePoint-Standarddatenbank beginnt mit STS_<Servername>_1, kann jedoch während der Installation Ihrerseits mit einem anderen Namen versehen worden sein.

Es ist nicht erforderlich, die in den Datenbanken enthaltenen Informationen auf deren Vollständigkeit zu überprüfen. Sie müssen lediglich überprüfen, ob die Datenbanken vorhanden sind.

Hinweis: Jegliche Änderung der Datenbanken oder Zeilen außerhalb des SharePoint-Dashboards oder des SharePoint API wird nicht unterstützt!

  3. Verlassen Sie die Anwendung SQL Enterprise Manager.

Überprüfen Sie die Internet-Informationsdienstinformationen.

  1. Rufen Sie über das Startmenü den Internet-Informationsdienst (IIS) Manager auf.

  2. Überprüfen Sie ob die Einträge für STSAdminPool, die Standardwebsite und SharePoint Central Administration aufgelistet sind. Da Sie zusätzliche virtuelle Websites erstellen können, um mehrere Einstiegspunkte bereitzustellen, sollte für jede Site ein virtueller Server vorhanden sein. Um zu prüfen, dass der virtuelle Server zum Betrieb SharePoint aktualisiert wurde, suchen Sie im Ordner <Name des virtuellen Ordners>\layouts\bin eines jeden virtuellen Ordners nach dem Eintrag Microsoft.SharePoint.ApplicationPages.dll.

  3. Verbinden Sie sich mit der SharePoint-Standardstartseite des Servers. Zum Beispiel: http://hsvnt094.

  4. Wählen Sie im Abschnitt Quicklinks auf der linken Seite des Dashboards die Dokumentbibliothek für gemeinsame Dokumente aus.

  5. Wählen Sie Dokument übertragen im Menü und versuchen Sie ein Microsoft Office-Dokument zu übertragen.

  6. Überprüfen Sie, ob das Dokument geladen wurde.

  7. Wiederholen Sie die Schritte 4 - 6 unter Verwendung einer Insight-Dokumentbibliothek.

Überprüfen Sie Inhaltsgenehmigungen und Dokumentversionen

  1. Wählen Sie die Seite Einstellungen und Spalten ändern der Dokumentbibliothek.

  2. Wählen Sie die Seite Allgemeine Einstellungen ändern der Dokumentbibliothek.

  3. Ist die Option Inhaltsgenehmigung oder Dokumentversionen aktiviert? Diese beiden Optionen sind standardmäßig deaktiviert. Wenn die Option Inhaltsgenehmigung aktiv ist, müssen alle Benutzer mit Berechtigungen für moderate Listen ein Dokument genehmigen bevor es in der Ansicht Alle Dokumente aufgeführt wird. Die Genehmigung ist nur für eine Version gültig. Bei jeder Änderung der Datei muss diese erneut genehmigt werden.

Falls SQL Manager nicht ordnungsgemäß installiert oder ausgeführt oder die SharePoint-Datenbank nicht richtig erstellt wird, findet sich die Ursache der Probleme in den meisten Fällen in der Installation des SQL Servers. Tritt diese Art von Problemen auf, müssen Sie alle Anwendungen mit Ausnahme des Windows 2003 Servers entfernen und neu installieren. Erfolgte die Installation mit WMSDE, schlagen Sie Anweisungen zum Übergang von WMSDE auf SQL Server bitte im Handbuch für Microsoft Windows SharePoint Services 2003.0 Administratoren nach.

Wenn Sie Probleme mit IIS oder SharePoint haben, müssen Sie SharePoint und IIS entfernen und neu installieren.

Treten Probleme bei der Verbindung mit einer SharePoint-Seite auf dem Server, dem Hochladen von Dokumenten auf den Server oder dem Ändern von Einstellungen auf dem Server auf, findet sich die Ursache der Probleme in den meisten Fällen in der Installation des SQL Servers. Überprüfen Sie bei dieser Art von Problemen, ob alle Benutzernamen und Kennwörter korrekt sind. Ist dies der Fall, entfernen Sie SharePoint und installieren Sie es neu.


Gesperrte Dateitypen

Administratoren können das Laden von Dateien mit bestimmten Erweiterungen in SharePoint verhindern. Überprüfen Sie die Liste, um festzustellen ob die Datei, die der Benutzer versucht zu laden, einem gesperrten Dateityp entspricht.

Stellen Sie sicher, dass die verschiedenen Solid Edge-Dateierweiterungen nicht in dieser Liste enthalten sind.


Servergeschwindigkeit

Es gibt mehrere Prozesse, die sich auf die Geschwindigkeit des Servers auswirken können. Falls Sie ein Nachlassen der Geschwindigkeit Ihres Servers feststellen, sollten Sie diese Prozesse überprüfen.

Virenprüfung

Mit SharePoint 2 können Administratoren festlegen, dass beim Übertragen und Herunterladen von Dateien eine Virenprüfung durchgeführt wird. Dies kann die Dateiübertragungsvorgänge sowie die Belastung des Servers wesentlich verlängern. Schauen Sie auf den SharePoint-Verwaltungshomepages nach, ob die Virenprüfung aktiviert ist. Ist dies der Fall, bitten Sie alle Benutzer Insight und SharePoint zu verlassen und führen Sie einen Zeittest durch, indem Sie das Cache eines Clients leeren und anschließend eine typische verwaltete Zeichnung öffnen. Speichern Sie, ohne irgendwelche Änderungen vorzunehmen und schließen Sie die Zeichnung. Wiederholen Sie diese Schritte, nachdem Sie alle Optionen zur Virenprüfung deaktiviert und IIS neu gestartet haben. Sie können IIS neu starten, indem Sie bei der DOS-Eingabeaufforderung iisreset eingeben. Beträgt der Zeitunterschied mehr als 5%, verursacht der Virenscanner eine Leistungsminderung.

HTML-Anzeige

Der HTML-Anzeigedienst konvertiert Dateien und Dokumente in ein darstellbares HTML-Format. Da die Anzeige nach Bedarf erfolgt kann sie eine große Anzahl von Ressourcen beanspruchen. Wir empfehlen für den HTML-Anzeigedienst immer einen separaten Server zu verwenden, damit dessen Ausführung nicht die Leistung Ihres Webservers beeinträchtigt. Weitere Informationen hierzu finden Sie im Abschnitt Configuring Usage Analysis des Handbuchs für Windows SharePoint Services 2003 Administratoren.

Verwendungsanalyseprotokollierung und -verarbeitung

Die Protokollierung der Verwendungsanalyse hat relativ geringe Auswirkungen auf die Servergeschwindigkeit. Gewöhnlich nicht mehr als 10%. Die Protokollaufbereitung wird jedoch separat vom Windows SharePoint Services-Prozess ausgeführt und stellt eine die Ressourcen stark beanspruchende Aufgabe dar. Die Protokollaufbereitung verwendet den SharePoint Zeitgeberdienst. Auf diese Weise können Sie den Leistungsverlust minimieren, indem Sie die Protokollaufbereitung auf einen Zeitpunkt verlegen, an dem Ihre Website gewöhnlich nicht stark besucht ist. Sie können außerdem die Anzahl der Protokolldateien erhöhen, um die Leistung bei der Protokollierung zu verbessern, oder aber die Anzahl der Protokolldateien reduzieren, um die Leistung bei der Aufbereitung der Protokolldateien zu verbessern. Weitere Informationen hierzu finden Sie im Abschnitt Configuring Usage Analysis des Handbuchs für Windows SharePoint Services 2003 Administratoren.

Website-Verwendungsbestätigung und automatisches Löschen

Diese Komponente hilft Ihnen Websites zu überwachen und zu löschen, die nicht verwendet werden. Sie verwendet außerdem den SharePoint Zeitgeberdienst, um die Prüfung nach nicht verwendeten Websites durchzuführen, Warnmeldungen über nicht verwendete Websites per E-Mail an die Administratoren der Websites zu senden und Websites automatisch zu löschen. Sie können wie bei jeder anderen den SharePoint Zeitgeberdienst verwendenden Komponente die Ausführung des Prozesses auf einen Zeitpunkt verlegen, zu dem Ihr Server weniger stark beansprucht wird. Da diese Komponente auf Ebene des virtuellen Servers gesteuert wird, können Sie außerdem deren Ausführung für die einzelnen virtuellen Server in Zeitabständen festlegen, damit nicht alle virtuellen Server zur gleichen Zeit auf nicht verwendete Websites überprüft werden. Weitere Informationen hierzu finden Sie im Abschnitt Managing Unused Web Sites des Handbuchs für Windows SharePoint Services Administratoren.

Warnmeldungen

Tägliche und wöchentliche Warnmeldungen haben keinen besonderen Einfluss auf die Leistung. Wenn jedoch eine große Anzahl von unmittelbaren Warnmeldungen gesendet wird, kann dies die Geschwindigkeit des Servers beeinträchtigen. Auch diese Komponente verwendet den SharePoint Zeitgeberdienst, so dass Sie die Zeitpunkte für tägliche und wöchentliche Warnmeldungen sowie auch die Intervalllänge für unmittelbare Warnmeldungen festlegen können. Wenn die Standardeinstellung alle 5 Minuten beträgt, können Sie diesen Zeitraum beispielsweise auf 15 Minuten verlängern. Sie können auch die Anzahl der Warnmeldungen begrenzen für die jeder Benutzer sich anmelden kann, damit der Server nicht mit Warnmeldungsanforderungen überlaufen wird. Da Warnmeldungen auf Ebene des virtuellen Servers gesteuert werden, können Sie außerdem deren Ausführung für die einzelnen virtuellen Server in Zeitabständen festlegen, damit nicht alle virtuellen Server zur gleichen Zeit Warnmeldungen versenden. Beachten Sie bitte, dass die einzige Möglichkeit zum Überprüfen der zum Senden von Warnmeldungen verbrauchten Serverressourcen darin besteht, Ihren SMTP-Server auf eine erhebliche Menge von ausgehendem Verkehr zu überprüfen. Weitere Informationen hierzu finden Sie im Abschnitt Managing Alerts des Handbuchs für Windows SharePoint Services 2003 Administratoren.

Serverereignisse und geplante Dienste

Jede mit benutzerdefinierter Programmierung durchgeführte zusätzliche Verarbeitung, die SharePoint Dokumentbibliothekereignisse überwacht, stellt eine zusätzliche Belastung des SharePoint Servers dar. Deaktivieren Sie, wenn möglich die Ereignis-Listener und geplanten Dienste und messen Sie die Benutzerleistung. Wenn sich die Leistung erheblich steigert, überdenken Sie die Notwendigkeit für Ereignis-Listeners oder suchen Sie nach Möglichkeiten die Leistung der Ereignis-Listeners zu erhöhen. Falls das Problem von einem geplanten Dienst verursacht wird, suchen Sie nach Möglichkeiten den Dienst auf einen Zeitpunkt zu verlegen, an dem er sich nicht auf die Hauptarbeitsleistung auswirkt, z.B. während des Backups.

Dashboard ist zu langsam

Überprüfen Sie die auf der Dashboardseite des Benutzers verwendeten Webparts und die Anzahl der damit angezeigten Objekte. Bei einer großen Anzahl (gewöhnlich mehr als 10) von Webparts oder Webparts, die Informationen aus anderen Ressourcen anfordern, versuchen Sie die Anzahl der auf der Seite befindlichen Parts zu reduzieren, um zu sehen, ob sich dadurch die Leistung verbessert. Sie können alle bis auf einen Webpart entfernen und die Parts anschließend Stück für Stück wieder hinzufügen. Wenn Sie versuchen Tausende von Listeneinträgen gleichzeitig anzuzeigen, verwenden Sie Filter und benutzerdefinierte Ansichten, um die Menge der angezeigten Daten zu reduzieren.

Schauen Sie außerdem nach, ob die Objekte wegen Ignorierung der Ordnerstruktur in der Liste angezeigt werden Ist dies der Fall, ändern Sie die Eintragsgrenze, fügen Sie einen Filter hinzu oder aktivieren Sie die Anzeige von Ordnern.

Systemmonitor

Überwachen Sie die Menge des verfügbaren Speichers sowie die CPU-Auslastung mit dem Windows Systemmonitor, um festzustellen, ob diese mit mehr als 80%-iger Auslastung verwendet werden. Ist dies der Fall, sollten Sie in Erwägung ziehen mehr CPU-Speicher hinzuzufügen oder zu einem Serverfarm-Setup zu wechseln, um den SQL- und Webarbeitsaufwand auf mehrere Systeme zu verteilen. Wir haben derzeit leider keinerlei Empfehlung wie Sie feststellen können ob Sie den vorhandenen Server vergrößern oder zu einer Umgebung mit mehreren Servern wechseln sollten.

3GB-Schalter

Zu diesem Thema liegen noch keine Empfehlungen vor.


Wählen zwischen Microsoft SharePoint Portal Server und Windows SharePoint Services

Insight V15 kann sowohl mit Microsoft Windows SharePoint Services 2 als auch mit Microsoft SharePoint Portal Server 2003 ausgeführt werden. Einzelheiten über die Neuheiten in den Anwendungen finden Sie unter:

SharePoint Portal Server 2003: http://www.microsoft.com/office/preview/sharepoint/whats_new_sps.asp

SharePoint Services 2003: http://www.microsoft.com/windowsserver2003/techinfo/sharepoint/whatsnew.mspx

Die Entscheidung darüber welches Produkt sich für Ihr Unternehmen am besten eignet, ist von Ihren Funktionsanforderungen sowie verfügbaren Mitteln abhängig.

Hinweis: Wenn Sie SharePoint Portal Server 2003 implementieren, installieren Sie nicht die abwärtskompatiblen Dokumentbibliothekkomponenten. Falls Sie diese Komponenten installieren, wird auch der Webspeicher auf dem Server installiert und SharePoint speichert daraufhin alle Dokumente nicht auf dem SQL-Server sondern im Webspeicher. Der Webspeicher hat sich von SharePoint Portal Server 2001 auf 2003 nicht verändert und Sie können bei dessen Verwendung nicht mehrere Server zum Speichern verwenden. Sie müssen daher Ihre Daten in zukünftigen Versionen von SharePoint migrieren, da Microsoft zu SQL Server als Speichermechanismus für SharePoint übergeht. Aus diesem Grund haben wir Insight und SharePoint Portal Server 2003 nicht mit den abwärtskompatiblen Dokumentbibliothekkomponenten getestet.

Falls es Ihnen schwer fällt sich zwischen Windows SharePoint Services und SharePoint Portal Server zu entscheiden, können Sie hier Microsofts 10 wichtigsten Gründe für die Verwendung von PortalServer nachlesen.

http://www.microsoft.com/germany/ms/sharepoint2003/warum/top-gruende/index.htm